Source SDK: Mastering the Source/Edit Menu

From Wikibooks, open books for an open world
Jump to navigation Jump to search
« Source SDK: Mastering the Source
Edit Menu
»
File Menu Map Menu

The Edit Menu on the Control Bar houses a variety of useful tools that can assist you in creating your map.

Undo(CTRL+Z)[edit]

This button undos any action or edit you've made to anything in your level. The undo button has a limit.

Redo(CTRL+Y)[edit]

This button gives you the opportunity to redo an undo. The Redo button has a limit.

Toggle Undo/Redo[edit]

This button toggles ON and OFF your ability to use the Redo and Undo tools.

Find Entities(Ctrl+Shift+F)[edit]

This button opens a small search box that allows you to search any entity you have in your level, in case you have misplaced them. (add image of find entity search box)

Replace...(Ctrl+Shift+R)[edit]

This button opens a small search box that allows you to take any entity in your map and replace it with another. (add image of replace search box)

Cut(Ctrl+X)[edit]

Cuts a selected brush or entity out of the level and onto your clip board, for it to be pasted.

Copy(Ctrl+C)[edit]

Copies a selected brush or entity out of the level and onto your clip board, for it to be pasted.

Paste(Ctrl+V)[edit]

Pastes whatever item you have in your clipboard onto the map. Because the button pastes the item as soon as you click it, making it difficult to aim where you paste it when using the drop down box, so it's smarter to use the hotkey.

Paste Special[edit]

Delete(Del)[edit]

Deletes any selected brush or entity within the map.

Clear Selection[edit]

De-selects any brush or entity you have selected in the map.

Select All[edit]

Simultaneously selects all brushes and entities in the entire map.

Properties[edit]

Shows the current properties of a selected entity.

« Source SDK: Mastering the Source
Edit Menu
»
File Menu Map Menu