Source SDK: Mastering the Source/File Menu

From Wikibooks, open books for an open world
Jump to navigation Jump to search
« Source SDK: Mastering the Source
File Menu
»
The Control Bar Edit Menu

The File drop down box is the first item located on the Control Bar. It allows you to save, run, and compile your map, as well as perform a number of useful configuration programs.

New(Control+N)[edit | edit source]

Creates a new blank map.

Open...(Control+O)[edit | edit source]

Open a previously created or downloaded map. A set of recently opened maps will appear at the bottom of the File drop down box, for easy access to a map you've previously been working on.

Close[edit | edit source]

Closes a currently opened map. Of course you can always skip this step and simply move onto opening another map, thereby closing the current map automatically.

Save(Ctrl+S)[edit | edit source]

Saves the current version of an already created map.

Save as[edit | edit source]

Saves a newly created map as a brand new file.

Export[edit | edit source]

Export Again[edit | edit source]

Export to .DXF[edit | edit source]

Run Map(F9)[edit | edit source]

Compiles and launches your map, allowing you to personally play test it in game. You do not have to save the changes to your map in order for them to appear in game. On occasion, if you accidentally press F10 instead of F9, you're temporarily unable to launch your map by hotkey, so simply use the button located in the File drop down box.

Convert WAD to VMT...[edit | edit source]

Reload Sounds[edit | edit source]

Exit[edit | edit source]

Closes out the Hammer Editor. Does not close out the Application Browser. Of course this can alternatively be done by clicking the red 'X' icon in the top right corner.

Notes[edit | edit source]

  • If you are currently editing a map when you select the new, open, close, save, save as, or exit button, a question box will appear asking if you'd like to save any currently unsaved changes to your map.
« Source SDK: Mastering the Source
File Menu
»
The Control Bar Edit Menu