PlanoTse Handbook for Job Search Automation/Domains & Directories

From Wikibooks, open books for an open world
< PlanoTse Handbook for Job Search Automation
Jump to navigation Jump to search
PlanoTse Handbook for Job Search Automation
PlanoTse Program Reference Domains & Directories Creating a Testbed

Data Domains & Data Directories[edit]

Data Root Directory[edit]

In its basic versions, PlanoTse stores all its data on your hard drives. Each data item, also known as data holder, is stored in a file, in XML format. All items of the same data type are stored in the same folder. All user data files are stored under the same data root directory.

For example, all script data holders are stored under the Scripts folder.

Personal Domain & Single Mode[edit]

Data domain is a sphere in which data items can interact with one another but not with items outside of this sphere of operation. At first use, the default data domain is called 'Personal'. In this case, your data directory would look similar to the one presented in the example below:

C:\Users\your-account-name\Documents\PlanoTse\MyData\Scripts

When you first run PlanoTse, the above directory, or a similar one, will be automatically created. To know for sure what it is, select the menu command [Tools » Directories » Data Root]. The default folder MyData is where all your data will be stored. In this case, you’re using PlanoTse in single-data-directory mode, or simply single mode.


Impersonal Domain & Dual Mode[edit]

The alternative is using the software in dual-data-directory mode, or simply dual mode, in an impersonal data domain. In order to be in dual mode, you need to first set up two directories: one for your real data and the other for your test data. This is strongly recommended when you have your personal version of the software and begin using the software to build up your data for real uses. Do the following steps to set up your impersonal data domain and use the software in dual mode.

  1. Create a new folder where you want to store your real data, e.g. D:\Data\DemoRealData
  2. Create a new folder where you want to store your test data, e.g. D:\Data\DemoTestData
  3. Run the software.
  4. Select [Tools » Options » Directories » Data Rooot » Reset Data Root] as shown in the above image.
  5. Enter the path you created in Step 1
  6. Select [Tools » Options » Directories » Data Rooot » Save Path » As Real Data Root].
  7. Select [Tools » Options » Directories » Data Rooot » Reset Data Root].
  8. Enter the path you created in Step 2.
  9. Select [Tools » Options » Directories » Data Rooot » Save Path » As Test Data Root].

Now you can use the dual mode by switching between test and real data directory using either of the following menu command:

  • [Tools » Directories » Use Test Data Root]
  • [Tools » Directories » Use Real Data Root]

When you’re using the test data directory, the main window paints its background yellow.

Managing Multiple Data Domains[edit]

You may choose to keep your data in several different domains. One of the available data holder types is a domain. To create a domain, select [Tools » Directories » Data Domains » New Domain]. Create a data domain definition then set its TestDir and RealDir to your directory paths. You can create as many domain definitions as you need to have. Each should have two different data directories: one for test and one for real data.

When you're ready to switch to a new data domain, select the menu command [File » Data Directories].




PlanoTse Handbook for Job Search Automation
PlanoTse Program Reference Domains & Directories Creating a Testbed