Blender 3D: Noob to Pro/Simple Vehicle: Another Shooting Machine

From Wikibooks, open books for an open world
Jump to navigation Jump to search

Contents

























Techniques[edit]

You should already know how to do:

  • Previous Simple Vehicle techniques

This section will introduce and recap:

  • Transform Locking (new)
  • Reuse of existing assets (new)
  • Application of Show/Hide (new)
  • Duplicate (recap) & Separate (new)
  • Parenting (recap)
  • UV Spheres (recap)
  • Changing object's pivot point (recap)

Caveats:

  1. I’m also learning Blender; if I’ve misrepresented anything please correct me
  2. I have Select With under Mouse on the Input tab of User Preferences set to Left whilst the “factory” setting is Right; if some of the following instructions containing  LMB  are not working mentally replace  LMB  with  RMB 
  3. I must use a 2 button mouse and cannot emulate a 3 button mouse (due to number 2 above) for orbiting around the viewport; instructions presented here use the Numpad for Orbiting

Overview[edit]

Fig. 01: Big Game Camera Rendered Model and Components

A simple Safari Big Game Camera for use on a photo safari will be created; a render of the completed product is provided at right (Fig. 01-A).  It is primarily based on cylinders and is comprised of three components (Fig. 01-B):

  1. Lens Casing
  2. Camera
  3. Swivel Mount comprised of four sub-components:
→ Front Support
→ Central Bracket
→ Stability Braces (2)
→ Ball Joint (from the Rocket Launcher)

To Abridge or not to Abridge ...[edit]

This tutorial turned out to be "a bit" (as my British friends would say) longer than initially anticipated. And that's alright, I had a lot fun – and learned a ton – making the Another Shooting Machine. Occasionally I may have provided a little more than you want in explanations or intellectual exploration. To address the desires of those who only want bare bones instructions an abridged version of this tutorial is available. All of the illustrative graphics – excepting those associated with the linked explanatory Supplements – in this full version are also in the abridged version.

The Abridged version does not have:

  •  KeyStrokes  or  HotKeys  (mostly: provided if a function has not been previously introduced in Noob to Pro)
  • In-line Blender icons supporting instruction clarity (mostly)
  • Clarification Notes or Hints
  • "Alternative approaches" exploration (including the Knife topology tool usage detail)
  • Linked explanatory Supplements (for those curious about the "why"s)

You can, and are encouraged to, try out both. If you've taken an extended hiatus from Blender I recommend following this full version, at least until you've refreshed your memory on key strokes.

To follow the full version simply continue here. OR access the Abridged Version.

Lens Casing – Base Model[edit]

If you have completed the Rocket Launcher tutorial:

  • Open the Rocket Launcher file
  • Select an unused visibility layer in the layer map ILI04-Visibility-Layers.jpg of the 3D View header, indicated by the absence of the little "used" circle for that layer
  • Add a Lamp if you expect to render the  scene; the default camera will work for the new layer but each layer to be rendered must have at least one Lamp
  • Just to be certain, Snap the 3D Cursor to the center

If you have not completed the Rocket Launcher tutorial, start a new file and delete the default cube.

Add Starting Cylinder[edit]

Fig. 02: Change Default Cylinder Orientation illustration
Fig. 02: Change Default Cylinder Orientation

Begin in Front Ortho view  NUM1 , ensuring “Limit Selection to Visible” is turned off ILI01-Limit-Selection-to-Visible-off.jpg

Add a cylinder mesh: sides=8, radius=1, depth=2, cap fill=nothing; rename the object (using the Outliner) to something unique and easily identifiable like Big Game Lens Casing

Remaining in Front Ortho and Object Mode, rotate the cylinder 22.5 degrees around the Y axis (the easiest (and most accurate) approach is to type 22.5 on the Y line of the Rotation section in the Transform Panel at the top of the Properties Shelf (press  N  to toggle its visibility at the right side of the 3D view). This will provide a horizontal flat surface for the top of the lens casing which will be used to create the handle. Because we want to ensure this orientation does not get inadvertently altered we will also lock this specific transform (Fig. 02).

Note:

The Properties Shelf and the Properties Window are two different animals. The Properties Shelf is toggled on and off with  N  and contains the Transform, Grease Pencil, Display & View, Background Images and Transform Orientations Panels. The Properties Window Blender269PropertiesIcon.png "factory" location is underneath the Outliner Window ILIp01-Outliner-Window-icon.png to the right of the main viewport; there is a page dedicated to the Properties Window in this Wiki Book.

 

Extend Starting Cylinder[edit]

Fig. 03: Create Lens Casing Base Model

Switch to Right Ortho view  NUM3 , enter edit mode by pressing  TAB  and execute the following steps (see (Fig. 03) for reference). Note: all units are Blender Units.

Switch to Vertex Select mode ILI06-Vetex-select-mode.jpg and select the “rear” 6 vertices using Border Select ( B ) then:

  1. Extrude on the “Y” axis .5 by pressing  E   Y   NUM.  NUM5  ENTER 
  2. Scale to 70% along the “X” and “Z” axes by pressing  S  followed by  SHIFT + Y  (not Y)  NUM.  NUM7  ENTER 
  3. Extrude on the “Y” axis 2.5 by pressing  E  followed by  Y   NUM2  NUM.  NUM5  ENTER 
  4. Repeat Step 2
  5. Extrude on the “Y” axis 1.5 by pressing  E  followed by  Y   NUM1  NUM.  NUM5  ENTER 
  6. Repeat Step 2

Lens Casing – Refining the Model[edit]

Adding Details[edit]

Fig. 04: Refine Casing Front End
  • Rotate the view counter-clockwise ( NUM4 ) until you get a nice view of the inside and outside combo.
  • Switch to edge select mode ILI01-Switch-to-Edge-Select.jpg and select a front edge.
  • Click  LMB on Select→Edge Loops (Fig. 04-A).
  • Extrude  E  followed by  ESC  to exit extrusion while retaining the newly created edges.
  • Scale to 90% along the “X” and “Z” axes by pressing  S  followed by  SHIFT + Y  (not Y)  NUM.  NUM9  ENTER  (Fig. 04-B).
  • Extrude on the positive “Y” axis .3 pressing  E  followed by  Y   NUM.  NUM3  ENTER ; this creates the visible interior of the lens casing. Press  F  to create the face which is our glass lens (Fig. 04-C).
  • Based on experience we know we will eventually be adding a Subdivision Surface ("Subsurf") modifier and can anticipate that action, so with glass lens face (and its attached edges) still selected press  Shift + E  to crease these edges with an edge crease factor of 1 (Fig. 04-D) in order to retain a sharp delineation between the lens casing interior and the glass lens.
  • Select an outside front edge and select Edge Loops on the Select Menu (as above) (Fig. 04-E). Scale to 120% along the “X” and “Z” axes by pressing  S  followed by  SHIFT + Y  (not Y)  NUM1  NUM.  NUM2  ENTER  to create the typical flared or belled mouth of the lens casing (Fig. 04-F).






Preparing for Subsurf[edit]

Fig. 05 Subdivision Surface Modifier Preparation
Fig. 05 Subdivision Surface Modifier Preparation

Return to Right Ortho view  Num3  and toggle "Limit Selection to Visible” ILI03-Limit-Selection-to-Visible-on.jpg on. Select an edge from each of the vertical edge loops – using  SHIFT + LMB  to add edges - and then 3D header Select Menu→Edge Loops. Rotate the viewpoint vertically towards you ( Num5 ) until you can see top fully. Deselect the top edges from the middle pair of loops ( SHIFT + LMB  on each edge to deselect) and crease the remaining selected edges ( SHIFT + E ) at a factor of 1 (Fig. 05).




Adding a Casing Handle[edit]

Handle Stem[edit]

Fig. 06: Extrude Handle Stem

For clarity’s sake we will divide the handle into two sub-components:

  • The vertical piece we’ll call the “handle stem”
  • The piece parallel with the lens casing body we’ll call the “handle proper”

Start by switching to Top Ortho view  NUM7 

Deselect all ( A )

Switch to face select mode ILI05-Face-select-mode.jpg and select the handle extrusion face (Fig. 06-A), Extrude 1 on the default extrusion angle  E  NUM1  ENTER  (Fig. 06-B).  Giving the handle a slightly slanted stem rather than a stem perpendicular to the casing results in a more “organic” looking handle.

Handle Proper[edit]

Fig. 07: Extrude Handle Proper

Switch to Front Ortho  NUM1 , deselect all  A  once or twice and select the front face of the handle stem (Fig. 07-A); just to be safe, rotate the viewpoint enough to verify the correct face (and only the correct face) is selected (Fig.07-B)

We could just extrude this face to create the handle proper but that would not result in a very functional looking handle.  Instead we will only extrude the upper 1/3 of the face, which will result in a nicely functional looking handle proper.

There are 3 approach options to accomplishing this

  1. Subdivide face, merge 10 vertices – requires the least knowledge but is the most time consuming
  2. Subdivide Left then Right edges sequentially, use the Knife topology tool and (optionally – see Handle Variations below) merge 2 vertices – less time consuming and potentially the most powerful
  3. Subdivide Left and Right edges simultaneously and (optionally – see Handle Variations below) merge 2 vertices – quickest/easiest for this specific case

All 3 are presented as has potential utility depending on the situation. This section became bigger than expected; the alternate approaches are described on a supplemental page: Face Subdivision Alternatives Supplemental page.

Extruding the Handle Proper[edit]
Fig. 12: Handle Proper Extrusion

Remaining in viewport orientation used for the “face work” above, deselect all  A  than switch to face select mode ILI05-Face-select-mode.jpg, ensuring “Limit Selection to Visible” is still on ILI03-Limit-Selection-to-Visible-on.jpg and the select the upper face (Fig. 12 inset).

Switch to Right Ortho view  NUM3  and extrude on the Y axis -2  Y  NUM−  NUM2  Enter .

Be sure to specify the Y axis in order to override the default extrusion angle (Fig. 12).

Finishing Up the Casing – No Materials Yet[edit]

Fig. 13: Smoothing Things Off

While still in Edit mode click  LMB  on the Modifiers icon ILI08-prop-pan-Modifiers.jpg at the top of the Properties Window and select the Subdivision Surface (frequently called Subsurf) modifier under the Generate column on the pop-up and use 2 subdivisions for both view and render. You should see an immediate change in the model to a much smoother look.

Exit Edit mode  TAB  and apply Smooth shading from the Tool Shelf. Voilà! The result should be fairly close to Fig.13-A.

If your results look closer to Fig. 13-B then some – or all – of the edge creasing needs attention.

If the results look similar to Fig. 13-C then the face the handle proper was extruded from has not been divided into thirds.

Handle Variations[edit]

Fig. 14: Variations on a Theme

As mentioned above the merging of vertices V09 and V12 (Fig. 07-D) into their respective lower corners is optional. That is because merging/not merging results in a discernibly different shape. When the original face is divided into three faces the inner curve between the underside of the handle and the top of the main casing body is much more open with the handle proper having a slimmer look (Fig. 14-A).

When the original face is divided into two faces – the top ⅓ of the original and the bottom ⅔ of the original – the inner curve between the underside of the handle and the top of the main casing body is quite smooth (Fig. 14-B).

Which one you choose is strictly personal preference.

Just for fun, Fig. 14-C depicts the result if the center face from Fig. 13-B is extruded instead of the upper face; hmmmm, that’s (maybe) potentially useful sometime …

QDRC Camera[edit]

A camera is a complex piece of equipment with many different pieces and creating a truly accurate model of camera could be a tutorial on its own. We must keep in mind, however, the function of this camera within our scene. It is a “supporting player” in the scene. It will be attached to a much larger lens casing, both of which will then be attached to a much, much larger object (a jeep). Since the focus of attention is intended to be the jeep we only need an object that at a distance provides the viewer with enough clues – in this case a general shape and coloration – to lead the viewer to the desired interpretation: they’re “seeing” a camera.

Fig. 15: Camera Base

So let’s create a Quick & Dirty Rude & Crude Camera …

Start by switching to Top Ortho view and add a cube, making sure you are in Object mode

In the Dimensions section of the Transform Panel of the Properties Shelf (Press  N  if it isn’t displayed) type in 1.5 for X, .75 for Y and 1 for Z (Fig. 15-A); rename the object (using the Outliner) to something unique and easily identifiable like Big Game Camera

Enter Edit mode  Tab , select all  A  and Bevel  CTRL + B  with an amount of .2 and 1 segment (default) (Fig. 15-B)

Fig. 16: Loop Cuts

Switch to Front Ortho view  NUM1  and then orbit until you have a nice view of the front and top, adding a Loop Cut with 4 cuts (Fig. 16)

Fig. 17: Face Extrusion

Switch to Face Select mode ILI05-Face-select-mode.jpg with “Limit Selection to Visible” on ILI03-Limit-Selection-to-Visible-on.jpg. Select the top central face and extrude .35 on the default (Z) extrusion axis  E  NUM.  NUM3  NUM5  (Fig. 17)

Fig. 18: Selective Merging

Switch to Vertex Select mode ILI06-Vetex-select-mode.jpg successively selecting the vertices at the bottom of the newly extruded section and merging them  ALT + M  with their nearest neighboring vertices towards the outside of the object and along the X axis (Fig. 18)


Fig. 19: Top Face Subdivide

Switch to Edge Select mode ILI01-Switch-to-Edge-Select.jpg and deselect All ( A ) and select both the top front and back edges.

Subdivide with two cuts

Switch to Vertex Select mode ILI06-Vetex-select-mode.jpg, Deselect All  A  and select the four exterior vertices of the combined three top faces using Circle Select  C  (Fig. 19)

Fig. 20: Shaping View Finder

Switch to Front Ortho view  NUM1 

Move the vertices -.15 along the Z axis  G  Z  NUM−  NUM.  NUM1  NUM5  Enter 

Scale 2.5 along the X axis  S  X  NUM2  NUM.  NUM5  Enter  (Fig. 20).

Fig. 21: QDRC Camera - Ready to Use

While still in Edit mode click  LMB  the Modifiers icon ILI08-prop-pan-Modifiers.jpg at the top of the Properties Window and select the Subdivision Surface modifier.

Exit Edit mode  TAB  and apply Smooth shading from the Tool Shelf.

As promised, you now are the proud owner of a QDRC Camera (Fig. 21)

Swivel Mount[edit]

The Swivel Mount is comprised of:

  • Ball joint providing the swivel movement
  • Stabilizing support (1), bracket (1) and braces (2)

Ball Joint[edit]

Fig. 22: Reusing the Rocket Launch Mount

If you have not completed the Rocket Launcher tutorial you can find the ball joint creation instructions at Create a mount instructions. When you finished the ball joint return here.

For those having completed Rocket Launcher, click  LMB  on the Rocket Launcher layer in the visibility layer section of the 3D View Header.

Since we were in Edit when the mount components were added to the Rocket Launcher the Cylinder and UV Sphere became an integral part of the Rocket Launcher object. The result is that we cannot simply copy the mount components in order to reuse them. Instead we now need to “extract” a copy of the mount's components (which are collectively referred to as the ball joint in this tutorial) from the Rocket Launcher object.
  • Select your Rocket Launcher object, enter Edit mode  TAB  and Deselect everything  A 
  • Select a vertex/edge/face (which is irrelevant) in both the cylinder and sphere that together create the ball joint and press  CTRL + L  to select the entirety of both components (Fig. 22-A)
  • Press  Shift + D  to create a duplicate, which automatically become the selection and move the selection into a clear area.
  •  LMB  to release, press  P  to bring up the Separation Menu and click on Selection (Fig. 22-B)
At this point we are still in Edit mode of the original object (Fig. 22-C). Note that the selection is now portrayed as an object outlined in red (selected but not active) and the Manipulator/Transform Widget has disappeared; this confirms Separation and informs us that nothing is selected in the actively edited object.
Exit to object mode  TAB . We now have two distinct objects and are ready to reuse the ball joint (Fig. 22-D).

Deselect all  A  and select the newly created ball joint. Move it  M  to the layer where you have the lens casing and camera. Take note that the Manipulator is hanging out in space rather than in center of the new object (Fig. 22-E). That is because an object “extracted” from another object carries with it the characteristics, including the origin, of the source at the point of Separation.

Well, that is easy to correct. To change the Origin characteristic click  LMB  on Set Origin→Origin to Center of Mass on the Tool Shelf. Now the Origin more accurately reflects the object to which it is attached.

 

Read this if you're having trouble remembering which layer contains what ... I know I do!

While in Object mode click on the Layers tab of the Tool Shelf to view/use the Layer Management capability. Layer Management enables the naming of visibility layers and facilitates management of visibility; quite handy. (This is an Add-on in Blender; if you don’t see a Layers tab go to the Add-ons section of User Preferences and look for “3D View: Layer Management”. If you’re not finding this Add-on mostly likely you’re using an older Blender version.)

Stabilizer Support, Bracket and Braces[edit]

Fig. 23: Rough Roads

We expect our Big Game Camera to be attached to body of a safari jeep which will be traveling over rough terrain (Fig. 23) at potentially high speeds. To provide stability in this demanding environment we’ll include a Front Support and Central Bracket in the package.

The Front Support and Central Bracket need to reflect the size and shape of the object to which they will be attached. We could start with a new cylinder and then manipulate it to achieve the desired size and shape. An easier, faster and more accurate approach is to start with the facet of the Lens Casing to which the stabilizing element will be attached.

Creating the Front Support Basis[edit]

Fig. 24: Support Prep
  1. Select the Lens Casing, switch to Right Ortho view  Num3  and enter Edit  TAB  mode ensuring “Limit Selection to Visible” is toggled off ILI01-Limit-Selection-to-Visible-off.jpg
  2. Select the 8 faces of belled front section using border or circle  B  or  C  (Fig. 24-A). Double check 8 faces are selected (using the Info header). If less than 8 are selected “Limit Selection to Visible” is not toggled off.
  3. Duplicate  Shift + D  ESC ; do not use  Shift + D  ENTER  in this situation, it will remove the selected faces from the model when they are separated.
  4. Separate the selection  P  similar to what was done with the Ball Joint but leave it in place – do not move; this will provide the starting point for the Front Support.
  5. Exit Edit mode  TAB .

Rename the new object – using the Outliner – to something unique indicating it is (will become) the Front Support. Take note of the yellow lines on the belled faces of the Lens Casing in Fig. 24-B; this indicates two (or potentially more) mesh areas are occupying the exact same space, which is exactly what we want this case.




Refining the Front Support[edit]

Fig. 25: Support in the Round

Select Front Support (if it is not already selected) and switch into Local View  Num/ . Local View is used here to avoid having the Lens Casing obscure our editing vision.

Enter Edit  TAB  and perform Loop Cut with seven cuts (Fig. 25-A)

While all of the Loop Cuts are still selected crease at a factor of one; deselect all, select an edge of the 2nd loop from the right and click  LMB  on Select→Edge Loops (Fig. 25-B).

Delete the loop  X  then selecting Edge Loops which results in a selected ring of faces that will become the Front Support (Fig. 25-C)

Invert the selection  CTRL + I  (Fig. 24-D) and delete unnecessary mesh  X , selecting Edges so that we now have the “foundation” for creating the Front Support (Fig. 25-E).

Switch to Vertex Select mode ILI06-Vetex-select-mode.jpg and select all ; scale 115% on the X and Z axes  S  SHIFT + Y  Num1   NUM.  NUM1  NUM5  (Fig. 25-F/G)

Extrude and escape  E  Esc  (Fig. 25-H)

Scale 70% on the X and Z axis  S  SHIFT + Y  NUM.  NUM7  (Fig. 25-I/J).

Exit Edit mode  TAB  to view results.

Whoops, not quite what was expected (Fig. 25-K) but no worries.

Re-enter Edit mode  TAB , switch to Face Select mode ILI05-Face-select-mode.jpg and select all  A .  Click  LMB  on Mesh→Normals→Recalculate Normals (or simply press  CTRL + N ).  You will immediately see a change in face orientation.  Upon exiting Edit mode  TAB  the problem is solved; now results equal expectations (Fig. 25-L).

Front Support – Finishing Touch[edit]

Fig. 26: Support Finishing Touch

Switch to Vertex Select mode ILI06-Vetex-select-mode.jpg and select the top 8 vertices using your preferred method (Fig. 26-A). Delete the 8 vertices  X  Vertices.

Select the 8 “open ended” vertices resulting from the deletion (Fig. 26-B) and give them Faces (Fig. 26-C) by pressing  F .

Exit Edit mode  TAB .

Finalizing the Front Support[edit]

Fig. 27: Support Quality Check

Switch out of Local View  Num/  to review the finished (excepting materials/textures) Front Support. Check shape, size and position to ensure they match intent (Fig. 27).

Create the Central Bracket[edit]

Fig. 28: Create Central Bracket

Repeat the same process as used for the Front Support (Fig. 28) with the following exceptions:

  1. perform Loop Cut with 7 cuts changes to perform Loop Cut with 11 cuts
  2. select an edge of the 2nd loop from the right changes to select an edge of the 3rd loop from the right
  3. scale 115% on the X and Z axes changes to scale 120% on the X and Z axes
  4. No “Finishing Touch” is required, we’ll use this one as a full circular bracket to enhance stability

Retaining Positioning[edit]

Fig. 29: Setting Parent

Once the support and bracket are where we want them we need to keep them in place. In fact, we want the brackets to retain their current relationship with the Lens Casing regardless of transforms performed on the Lens Casing. We will use Parenting to keep the brackets–Lens Casing relationship stable. Select the Front Support and the Central Bracket and lastly the Lens Casing using  SHIFT + LMB .

The order of selection is irrelevant with the exception of the last one selected; last selected is active and will be the Parent (master).  Click  LMB  on Object→Parent→Object→Object (Keep Transform) from the 3D header or it can be set using the Tool Shelf (Fig. 29).  Now whatever we do with the Lens Casing the Front Support and the Central Bracket will “tag along”.

Alternate Bracket Creation Approach – Extrusion[edit]

Fig. 30: Extrusion Approach

Another approach to creating the brackets is to make them integral to Lens Casing mesh itself through the use of Loop Cuts and Face Extrusion (Fig. 30-A). Using Loop Cut/Extrusion has the following benefits:

  • it is easier and quicker
  • it eliminates the need for additional positioning during creation
  • the bracket will retain its proper relationship with the Lens Casing regardless of how the object is transformed post-creation without the complexity of Parenting

There are, however, at least two drawbacks to the Loop Cut/Extrusion approach.

  1. Even with all bracket edges creased at a factor of 1 and with the Smoothing Correction modifier applied there remains an unwanted shine between the Lens Casing body and bracket (Fig. 30-B). With two separate objects and use of parenting the shine problem is resolved by avoiding the problem.
  2. There may be design changes or may want to reuse all or portions of the object (s) for some other project. If the bracket is integrated into the Lens Casing mesh it restricts our future options. In developing brackets and braces I became dissatisfied with the bracket positioning and their implied function. Had the bracket been integrated into the Lens Casing object not only would making the change have been a lot more work, portraying the functional change of the front bracket could not have been accomplished (Fig. 30-C).

Adding Bracing[edit]

Incorporating the Ball Joint[edit]
Fig. 31: Positioning Ball Joint

The bracing will stabilize the connection between the Lens Casing, the camera and the Ball Joint. Since even a Big Game Camera and Lens Casing are typically smaller than a rocket and its launcher (even a little rocket that can fit in the back of a jeep) we’re going to scale the Ball Joint down a bit.

Switch to Right Ortho view  NUM3  remaining in Object mode.  Select the Ball Joint object  LMB  and scale it to 90%  S  NUM.  NUM9  ENTER .

Enter Edit mode, select  LMB  a shaft element (vertex, edge or face) and press  Ctrl + L  to quickly select the whole shaft.

Scale the shaft to 60% on the X and Y axes  S  followed by  SHIFT + Z  (not Z)  NUM.  NUM6  ENTER .

Exit Edit mode and position the Ball Joint so that the shaft intersects with the bottom of the Central Bracket; the top of the object outline will disappear when full intersection (no gaps) is achieved (Fig. 31). Positioning of the Ball Joint relative to the Central Bracket is perhaps easiest to see by:

  • Selecting both objects
  • Switch into Local View  NUM/ 
  • Switch to Front Ortho view  NUM1 
  • Change the Method to Display/Shade Objects in 3D View in the 3D header from the default Solid ILI07-Solid-View.jpg to Wireframe ILI08-Wireframe-View.jpg or press  Z 
  • Click  LMB  on the Central Bracket which should make the Central Bracket active while the Ball Joint remains selected but is no longer the active object
  • Parent the Ball Joint to the Central Bracket so it retains its position relative to both Central Bracket and the Lens Casing.

Switch out of Local View  NUM/  and back to Solid View  Z .




Creating/Positioning the Braces[edit]
Initial Set-up[edit]
Fig. 32: Bracing Setup

Select the Front Support and switch into Local View  NUM/ .

Switch to Top Ortho view  NUM7 .

  • Snap the 3D Cursor to the Support’s center  LMB  Object→Snap→ Cursor to Selected.
  • Add a cylinder sides 8, rad=.25, depth=2 (default) and Cap Fill Type=Nothing.
  • Similar to what was done when starting the Lens Casing rotate 22.5 degrees around Z by typing 22.5 on the Z line of the Rotation section in the Transform Panel of the Properties Shelf (Fig. 32-A). This will be the Front Brace – you may want to rename it as such now.
  • Change the Method to Display/Shade Objects in 3D View in the 3D header from the default Solid ILI07-Solid-View.jpg to Wireframe ILI08-Wireframe-View.jpg or press  Z 
This will make seeing what we’re doing easier.
  • Switch to Front Ortho view  NUM1  and use the Manipulator to move the Front Brace down (negative direction) the Z axis until top is just above lower surface of the Front Support (Fig. 32-B). Switch to Right Ortho view  NUM3  and check to ensure proper Y axis alignment (Fig. 32-C).
  • Keeping the Front Brace selected select the Front Support and set the Front Support as Parent to the Front Brace.

Change from Wireframe View back to the default Solid View and switch out of Local View  NUM/ .

Transform a Cylinder into Braces[edit]
Fig. 33: Brace Creation

Deselect all  A  upon returning to Global View then select the Front Brace and enter Edit mode  TAB .

  • Deselect all  A , switch Vertex Select and select the bottom 8 vertices ( B  or  C ).  Use the manipulator to move the vertices into the sphere of the Ball Joint just above its center (Fig. 32-A).
  • Exit Edit  TAB , duplicate the Front Brace  Shift + D  Enter  and click  LMB  Object→Apply→Rotation and Scale to reset any transform parameters to zero. Note the Front Brace origin is no longer in center of the object (Fig. 32-B); click  LMB  on Set Origin→Origin to Center of Mass on the Tool Shelf. Now the origin is where we need it for proper mirroring (Fig 32-C).
  • Click  LMB  Object→Mirror→Global Z  Enter  to create the Rear Brace (Fig 32-D).

Use the manipulator to position the top of rear brace just inside the bottom of camera. The bottom of the rear brace is now “hanging” in mid-air unconnected to the Ball Joint where it needs to be. Enter Edit  TAB  mode to solve the problem.

  • Deselect all  A  and select the bottom 8 vertices ( B  or  C ). If we attempt to position the bottom vertices into the Ball Joint as was done with the Front Brace you’ll see that the diameter of the Rear Brace becomes smaller. Our objective, however, is to keep the diameters of both braces identical.
  • Go to the 3D header and find the 3D Manipulator Widget section and change the Transformation Orientation from Global to Normal. Now we can extend the length of the brace so that the bottom vertices are just inside the Ball Joint without impacting the brace’s diameter (Fig. 33-E).

Exit Edit  TAB  mode.  That completes the Stabilizer components with the Ball Joint securely connected to the Lens Casing and Camera (Fig. 33-F).

Pre-Textured Model Review[edit]

Fig. 34: Hierarchically Connected

Chapeau! You’ve completed modeling the Safari Big Game Camera. Take moment to review how the Outliner is displaying the model components. With the Parenting we’ve set up to prepare for mounting the assembly on the back of the forthcoming Jeep we’ve also set up a hierarchy of the model’s components. Whatever is done to the Big Game Camera Casing (which I've named BGC Lens Casing (Fig. 34)) – in terms of location, orientation and scale – the children elements will follow along.

Bringing it to Life[edit]

One of the primary objectives of 3D Modeling is to create a 2D rendition conveying a 3D feel that communicates one –or more – specific messages to a target audience. Despite all the hard work you’ve done to create this model (which is – I hope – SAVED to your storage device) it is not yet ready for public consumption:

  • colors (called materials in 3D land and for good  reason: materials encompass much more than color, even when the word “color” is used in it’s broadest, non-technical sense) need to be added
  • lighting needs to be set up (lamps in Blender)
  • and the 3D model converted to the 2D rendition (rendering) before it is ready for dissemination to the target audience. What follows is only a cursory exercise in materials, lighting and rendering; entire books have been written on each of the three topics.

Adding Zing! with Materials[edit]

Fig. 35: Base Material Selection

Material selection can make or break a project. Material selection also happens to be very subjective. Regardless of the science underlying material selection – and especially material combinations – many individuals will either like or not like what they’re viewing without being able to specify why. To make things even more intriguing, material preferences, material combination preferences and subliminal material messages are also strongly influenced by culture. The particular materials I’ve chosen simply reflect my personal tastes and you are encouraged to substitute your own preferred materials.

In addition to material selection, lamp selection and setup will also dramatically influence how the final render will appear. Using the default Point lamp with no material applied to the Big Game Camera results in a dull grey look when rendered (Fig. 35-A), which is not my objective. My objective is to have a base material of brilliant white (Fig. 35-D) that will be contrasted with a material that accentuates the object’s geometry. [Hint: Click on the Materials context Materials button.png in the Properties Blender269PropertiesIcon.png window to access Fig. 35-B/C.] The Lamp set up used in this tutorial is explained in the Render section.

Lens Casing Materials[edit]

There are four different materials to be created for the Lens Casing:

  1. the base material which is the dominant color of the object
  2. an accent material used emphasize geometric transitions
  3. an inside front rim material
  4. a lens glass material
Base Material[edit]

The default starting material provided the desired look (HEX CODE E7E7E7 in v2.79). If you are unsure how to create a new material using the default characteristics and/or how to apply it to an object please review Quickie Material and Multiple Materials Per Object before continuing.




Accent Material[edit]
Fig. 36: Apply Accent Material

Once you’re satisfied with base material, the mesh areas that display only that material can be hidden to make it easier to work on accents and fine details. Let’s start with the accent material:

  • ensure Limit Selection to Visible is toggled off
  • select the three main shank sections comprised of horizontally oriented faces using border select  B  (Fig. 36-A)
  • press  H  to temporarily hide the selection
  • select all faces remaining visible  A  (Fig. 36-B)
  • deselect the glass lens and inner rim faces  B  Shift + LMB  (Fig. 36-C)
  • orbit the view a bit  Num4  to double-check that only faces intended to receive the accent material are selected (Fig. 36-D)
  • add a new material in the Materials context of the Properties Window – or use one you’ve already created – (Fig. 36-Inset) and assign the material to the selected faces

The accent faces should now show the accent material color (Fig. 36-E).

Press  H  to hide the accent faces. Exit Edit mode  TAB  to seeː

  • changes on the full model
  • assure yourself that hidden faces are indeed still there ;-)
Inner Rim Material[edit]
Fig. 37: Apply Inner Rim

Select all  A  to ensure only the inner rim and lens glass faces are remaining (Fig, 37-A).

  • Deselect all  A  and select  LMB  the lens glass face (Fig. 37-B).
  • Invert selection  I  and the selected faces will now be the inner rim faces (Fig. 37-C)
  • Create a material for the inner rim. I used “matte” black (no gloss; Diffuse=HEX CODE 393939 with Specular=0.05) to minimize unwanted light reflections onto the lens glass.

Assign the material to the inner rim faces (Fig. 37-D) and hide the faces  H .

Lens Glass Material[edit]
Fig. 38: Add Lens Glass Material

Select all  A  to select the only remaining face (or you can simply click  LMB  on the face).

  • Create a new material and leave it at the default; we’re going to add a texture to this material as explained Image Textures
  • Select the red and white checkerboard representing Texture context Blender255TextureContextButton.png to right of the Materials context in the Properties Window (Fig. 38-A).
Before proceeding with material/texture you will need a suitable picture of lens glass. You can use the one I created (so it isn’t copyrighted) or find one you prefer on the web. To use mine, right click on Lens Glass Pic.jpg below (I suspect you know the drill) and save to your local computer.
  • Select Image or Movie for the Type (Fig. 37-B) and click on Open (Fig. 37-C). Navigate to the lens glass image file and open it.
  • When you are returned to Blender note that (1) the image is displayed in the Preview pane and image information is provided (Fig. 37-D). You can leave all other settings at their defaults.

Click on the Materials context icon and Assign the material to the lens glass face. Exit Edit mode  TAB  to see the changes .

Non-copyrighted lens glass image.[edit]

Lens Glass Pic.jpg

Fig. 39: Share Alike Lens Glass Image
Quickie UV Unwrap[edit]
Fig. 40: Results of UV Unwrap

Rotate the model’s front rim towards you until you can clearly see the lens glass face. It should look similar to what is shown at right. All of the materials are applied as intended with glaring exception of the lens glass (Fig. 40-A), because in Solid View mode textured-based materials are not displayed.

Change the Method to Display/Shade Objects in 3D View in the 3D header from the Solid ILI07-Solid-View.jpg to Material ILI09-Material-View.jpg; you will need to make the change by clicking  LMB  on the icon in the 3D header as  Z  only works for toggling between and Solid and Wireframe. Now it is possible to see a material’s texture in the 3D display without rendering.

Results are still not matching intent. The texture looks like it is scrambled. Why? Well, this Wikipedia article on UV Mapping gives some very strong clues. To summarize: the output isn't really scrambled. Lacking sufficient information Blender is creating triangular "slices" of the texture image and applying to all of the faces.

In the Image Texture tutorial in which a square checkerboard was applied to a cube Blender could determine how to apply the image to the object using the Mapping instructions of the Texture context since there was only a single face – having a same proportions as the texture image – to which the image needed to be applied. To tell Blender how we want the image texture applied to the object in this tutorial’s situation – a multitude of faces (calculations are performed on the faces generated by Subsurf) none of which have the image's proportions – we need to use UV Unwrapping:

  • enter Edit mode  TAB ; select the lens glass faces (if needed)
  • click  LMB  Mesh→UV Unwrap→Unwrap

Even with the face selected and still in Edit mode you will see the texture image appear on the lens glass faces as a single image.

Exit Edit mode  TAB  and you will see the applied texture image much better. It still doesn’t look quite right though; specularity is too strong and sharp. To correct that reduce Specular Intensity to .1 and Hardness to 15 (Hardness is the spread of the specularity, the lower the value the greater the spread and the softer the specularity border).  Now specularity complements the selected image texture (Fig. 40-B).




A Minor Hiccup[edit]
Fig. 41: Optical Illusion Partially Resolved

That completes application of materials to the Lens Casing. And it is looking pretty good (Fig. 41-A).

Except … if we look closely at the rear section of the Casing it sort of appears to slant downwards. It is difficult to see for sure with white of the Lens Casing against the light blue background.

Let’s give it darker background and yes, it definitely appears as though rear section has a downward tilt (Fig 41-B). We know it does not tilt downward because of the manner in which we created the model. It must, therefore, be an optical illusion, most likely caused by the curvature of the handle stem as it merges into the Casing’s rear section.

One option for correcting the illusion is to redesign (and obviously remodel) the handle, which would entail substantial time spent on rework. Another option is to provide a visual “clue” that would counter the illusion by reinforcing the horizontal structure of the Casing shank. Two parallel stripes down the shank running from the front to the rear should correct the illusion and be fairly quick & easy to implement.

The stripes are added by simply:

  1. press  SHIFT + H  to reveal the hidden faces
  2. apply a Loop Cut with 8 cuts to the side face of the shank
  3. use select edge/select loop/delete loop to quickly select stripe faces
  4. assign the accent material (Fig. 41-C)

The good news is that the stripes do counteract the illusion. The not so good news is that when the Loop Cuts were added the Subsurf algorithm flattened the area around the cuts resulting in a very noticeable flattening of the front rim (Fig. 42-D).

Use  CTRL + Z  or the Tool Shelf’s Undo History (my preferred approach) to revert to before the Loop Cuts were applied.

Optical Illusion Resolution[edit]
Fig. 42: Optical Illusion Fully Resolved

Since the stripes appear to correct the optical illusion we need to create the stripes whilst leaving the front rim pristine (untouched).

While still in Object mode click  LMB  the Modifiers icon Blender255ObjectModifiersContextButton.png at the top of the Properties panel (ILI08) and Apply the Subsurf modifier.

Enter Edit mode  TAB  to find that a lot of now permanent faces are now available to us (at a small ploy-count cost) (Fig. 42-A)

Select faces which in aggregate will provide the stripes (Fig. 42-B) and Assign the Accent material.

That does the job; the illusion issue is resolved and the circular curvature of the front rim is intact (Fig. 42-C).

QDRC Materials[edit]

Fig. 43: QDRC Fully Clothed

We will give the QDRC Camera the traditional black and silver two tone look which requires two materials:

  • main body area
  • viewfinder area

Select the Camera object

  • click  LMB , on the Materials context icon at the top of the Properties Window
  • click  LMB  the “+” sign to create the first material slot then click  LMB  on “New”
  • click  LMB  on the default name type in Camera Body
  • click  LMB  on the Diffuse color swatch and move darkness slider to the bottom (darkest) – leave other options at their defaults
  • enter Edit  TAB  and switch Limit Selection to Visible off
  • select the upper faces (Fig. 43-A) using Border select  B 
  • create another new material naming it something like Camera Viewfinder and make the following changes to the defaultsː
  1. check the checkbox for Mirror
  2. in the Mirror section set Reflection to .2 and Depth to 4

Exit Edit mode  TAB  to see your completed Two Tone QDRC Camera (Fig. 43-B)!

Swivel Mount Material – Create[edit]

Fig. 44: Swivel Mount Texture

All Swivel Mount components have the same material. The intent is to create rugged dull metal look.

Select any one of the components and create a new material, naming it something appropriate.

  • set Diffuse to HEX CODE=5E5E5E
  • click on the Texture context icon in the Properties Window (Fig. 44)
  • add a new texture and select Noise for the type
  • make the following changes to the defaults:
  1. activate Influence/Diffuse/Intensity and set to .75
  2. activate Influence/Diffuse/Color, leaving it at 1
  3. activate Influence/Shading/Emit and also leave it at 1
  4. change the Blend from Mix to Divide
  5. click on the default pink color and set the Hex value to BFBFBF
  6. change the DVar from 1 to .4
Swivel Mount Material – Apply[edit]
Fig. 45: Swivel Mount Textured

Click on the Materials context icon and apply the material (one at a time) to the remaining Swivel Mount components. After the material is created you can (with the Material context active):

  • select a Swivel Mount component
  • click  RMB  on the Material sphere next to the material name
  • select the material on the “fly-out” panel (Fig. 45) from the list of all the materials created in this Blender file, or
  • use the search capability at the bottom of the panel

If no other materials have been created for the object the selected material will be automatically applied to the object

Project Status Overview – Outliner Hierarchy[edit]

Fig. 46: Project Status

Good job on getting this far!  Before we move to the final step (rendering) let’s take a bit of breather and review what has been accomplished. One way to do that is using the Outliner which provides a structured, organized and comprehensive “snapshot” of the status (Fig. 46). Using the content of the Outliner it is quite easy to identify:

  1. the hierarchical relationships ILIO-hierarchy-symb.jpg between the high level components of the project
  2. which primitive meshes ILIO-primative-symb.jpg provide the base for the object
  3. the consistency and logic of naming conventions
  4. the materials ILIO-materials-symb.jpg associated with different objects, down to the names of image texture files
  5. which (if any) Modifiers ILIO-modifiers-symb.jpg are active for each object

The granularity of this information facilitates model maintenance/changes, asset re-utilization and – potentially – problem solving.

¡¡Camera – Lights– Render!![edit]

Now that you’ve created the Safari Big Game Camera it is time to transform – or render – the results of your hard work into a format shareable with others. Rendering is a BIG subject comprising at a minimum:

  • selecting a rendering engine (internal Blender Render used here)
  • positioning and adjusting the camera(s)
  • selecting, positioning and adjusting lights (or Lamps in Blender terminology)
  • providing a presentation setting

Exploring any of the items listed above in their entirety is well beyond the scope of this tutorial. There are, however, some very simple things we can do to create an attractive rendered result.

Camera[edit]

Fig. 47ː Camera Set Up

Positioning and aiming of the (single) camera in this tutorial uses the “Lock Camera to View” capability which is based on the simplistic WYSIWYG (what you see is what you get) principle. To activate this function:

  • toggle Property Shelf visibility if needed –  N 
  • find the View Panel (3rd panel down with factory settings) and click on the checkbox to the left of “Lock Camera to View” (Fig. 47)

Now camera positioning/aiming can be accomplished quickly and easily:

  • select all BGC components ( B  or  Shift + LMB )
  • activate the camera viewpoint  NUM0  (Fig. 48 Camera Persp)
  • press  NUM.  to center the BGC components in the view space
  • adjust to your satisfaction by panning and zooming (which may illustrate a constraint inherent to the Lock Camera approach, namely it can get you close but it may not be “perfect”)
  • you can fine tune the positioning using the Manipulator but use with caution: this actually moves the objects – it is not just for camera positioning/aiming




Lighting[edit]

Fig. 48ː Lighting Set Up

A single Hemi Lamp with Energy set to .8 is used for the renders in this tutorial. To switch to the depicted Quad View first activate the camera viewpoint  Num0  then press  CTRL + ALT + Q . Position the Lamp (Fig. 48) using the Manipulator in move and rotate modes.

Alternatively, you can quickly position using the values provided in the Fig. 48 Inset:

  1. click on the lamp to select making sure it is the only thing selected
  2. toggle Property Shelf visibility if needed and enter the values provided in the Location area
  3. the values are relative to the position of the BGC components

Setting[edit]

Fig. P1ː Render Backgroundː Elephants (no copyright)
Fig. P2ː Render Backgroundː Leaping Tiger (no copyright)

To provide the presentation Setting we’ll give the World context a render background derived from a standard image. The image should explicitly or implicitly invoke the feeling of a big game safari. You can use either (or both) of the images in Fig. P1/P2 or find one you prefer on the web. Neither P1 nor P2 is copyrighted. The elephants image is from WikiCommons and the tiger image is my own creation using Photoshop and starting from a royalty-free image. To use these, right click on the image and save to your local machine.

Image aspect and sizing is the Render context default.

Render Background Texture[edit]

Fig. 49ː World Background -- Texture

The following steps associate your selected image with a World entry so that Blender knows to display it as the render background:

  1. click  LMB  on the World context icon ILI10-World-context-icon.jpg at the top of the Properties Window
  2. and then on the “+” sign to the right of a World name (Fig. 49-A) to create a linked World entry which is a clone of the original
  3. click on the “X” adjacent to the “+” sign to unlink the clone and reset the entry (Fig 49-B)
  4. click on the New button (Fig. 49-C) which has replaced the named clone to create a fresh World entry named World.xxx
  5. rename the entry then click on the Texture context icon (Fig. 49-D) to create a texture linked to the new World entry
  6. click on “New” to create a new Texture entry (Fig. 49-E)
  7. similar to how a texture was identified for a material, select “Image or Movie” for Texture Type and click on “Open” to browse to the background image location
  8. after returning to Blender – where the image info is displayed – scroll towards the bottom of the Texture context to the Influence Panel (Fig. 49-F)
  9. click on the checkbox to the left of Horiz:
  10. Blend: should be checked by default; if isn't, check it also
  11. return to the World context
Fig. 50ː World Background -- Rendered

Click on the “Paper Sky” checkbox in the World Panel of the World context to activate the image for use as the render background and align to your render dimensions. Press  F12  to view the final results of efforts in a render.

Congratulations … you’ve completed this tutorial!  I enjoyed making it and I hope you found it enjoyably educational.