ZK/How-Tos/Issues

From Wikibooks, open books for an open world
< ZK‎ | How-Tos
Jump to: navigation, search

Issues[edit]

Upgrade Issues[edit]

  • how to resolve javax.servlet.ServletException: Only one layout servlet is allowed in one context
  1. please remove the older jar of ZK first.
  2. put the new zk jar into web-inf\lib
  3. also check there is any zk jar files in the common/shared lib of the application server.
Below is the core zk jar list of different version.,
 2.4.1
      zcommon.jar
      zhtml.jar
      zk.jar
      zkplus.jar
      zul.jar
      zweb.jar
 3.0RC
      zcommon.jar
      zcommons-el.jar  *new since 3.0RC
      zhtml.jar
      zk.jar
      zkmax.jar        *new since 3.0RC
      zkplus.jar
      zml.jar          *new since 3.0RC
      zul.jar
      zweb.jar
 3.0RC2
      zcommon.jar
      zcommons-el.jar
      zhtml.jar
      zk.jar
      zkmax.jar
      zkplus.jar
      zml.jar
      zul.jar
      zulex.jar        *new since 3.0RC2
      zweb.jar
 3.0
      zcommon.jar
      zcommons-el.jar
      zhtml.jar
      zk.jar
      zkex.jar         *rename from zulex.jar since 3.0
      zkmax.jar
      zkplus.jar
      zml.jar
      zul.jar
      zweb.jar

To make sure there are no other conflicts. For example, two mysql jdbc drivers in the tomcat/lib makes this exception, too.

Server Issues[edit]

Web Servers that don't support JSP 2.0[edit]

ZK 3.0 or later[edit]

ZK allows developers to use EL expressions, but it doesn't require the Web server to support JSP 2.0. ZK actually doesn't depend on JSP any more.

ZK 2.4 or earlier[edit]

For those who use older version of ZK (before 3.0), it is possible to configure an old Web server to support JSP 2.0 as described MyFaces's Installation.

The basic idea is to copy jsp-api.jar to the proper directory, which depends on the Web server. For example, the directory is common/lib if Tomcat 4.1.x is used.

If you find a way to enable ZK on an old Web server, don't hesitate to share the information with us by adding them the proper section above.

The jsp-api.jar file can be found in Tomcat's download, or ZK Subversion.


Browser Issues[edit]

Firefox[edit]

Cursor lost in overlapped over a Div with "overflow:auto"[edit]

This issue existed in Firefox's bugs-list for a long time. -- input field over div with overflow has no input cursor

Hope


OS Issues[edit]

Notes in Linux[edit]

 1.remember to set headless and DISPLAY in linux
   export DISPLAY=:1.0
   export CATALINA_OPTS="-Djava.awt.headless=true"