PyKDE Programming/Introduction

From Wikibooks, open books for an open world
Jump to: navigation, search

Requirements[edit]

This book requires a basic understanding of Python and Linux. In order to follow the material taught the following programs and libraries should be installed:

  • Python2.6 (since PyKDE4 is not ported yet to Python3)
  • PyKDE4
  • PyQt4

How to read this[edit]

This book is organized in three major parts

  • Building KDE Applications
  • Creating Qt based GUIs
  • Bringing the two concepts together