Mewa Film User's Guide/Getting started

From Wikibooks, open books for an open world
< Mewa Film User's Guide
Jump to: navigation, search

Getting Mewa Film[edit]

Mewa Film is available for windows and linux and can be downloaded from www.mewatools.com.

Software requirements[edit]

Mewa Film performace depends imensily on the graphics hardware, this mean that by using better graphics card you will get better performance. To run Mewa Film you will need a graphics card with, at least, 256 MB of memory, must support OpenGL 2.0 or later and Pixel Buffers. Any modern graphics card supports that.

Installing[edit]

Mewa Film Windows Installer

Microsoft Windows[edit]

The Microsoft Windows version of Mewa Film is distributed as an executable installer. To install, double click on setup-MewaFilm<version>.exe (where <version> is a number) and follow the installation instructions.

Once installed you can run Mewa Film by double-clicking the Mewa Film shortcut on your Windows desktop or if you have agreed to install a Mewa Film shortcut in the start menu, choose the program at Start Menu > Programs > Mewa Film > Mewa Film.

Linux[edit]

Once downloaded the linux rpm, to install the rpm one way is at a console prompt, type rpm -ivh mewafilm-<version>-<distribution>.rpm with root permissions. Some linux distributions provide graphical solutions to install rpms.

To start Mewa Film just type mewafilm at a console prompt.

To uninstall Mewa Film type rpm -e mewafilm at a console prompt.

Getting the best performance[edit]

To get the best performance it's recommended to increase the system memory (also called RAM) that Mewa Film can use. To do that choose the menu Edit >> Preferences.

Preferences dialog

In the hardware section adjust the amount of memory you want to make available to Mewa Film. Half the memory supported by your computer is a safe amount. If you select more memory than the one supported by your computer, your computer might become very slow, due to the use of virtual memory.

Creating a project[edit]

When lauching Mewa Film, it's main window appear with almost every button disabled. This is because a new project needs to be created before we load and edit any footage.

Main window after stating Mewa Film

To create a new project choose the menu button File > New Project or click NewProjectButton.png in the toolbar.

New project dialog

The new project dialog appears. The first input field is the name of the project. The second input field shows where the project will be stored, is good idea to leave it as it is as it is easier to find a project if all projects are kept in the same directory.

Next we have the project options. The rendering options are used when rendering your work to a final footage. You can choose the frame resolution and frame rate for your result footage. Mewa Film supports resolutions up to 2048x2048.

Then we have the thumbnail size, which gives the possibility to set the size of the thumbnails, used in montage. Setting the thumbnail size of your project can be very usefull if you want to edit several footage with different aspect ratios. With all thumbnails resized to fit the same rectangle size, the different aspect ratios can be observed. The default thumbnail size is 160x120, which correspond to an aspect ratio of 4:3.

Now just press the Create button to create the project.

Once the project is created, or loaded, the name of the project appears in the application title bar (top left corner).

Some notes on project files: Project files have extension .filmproj, but if you want to copy the project to a different place you need also to copy the media folder, which contains all the media used by the project. The media folder is in the same location as the project file (.filmproj) and has the same name as the project.

Importing footage[edit]

Before editing any footage, the footage needs to loaded. We import footage by selecting the menu option File > Open > Footage or pressing OpenFootageButton.png in the toolbar. The Open Footage dialog appears,

Open footage dialog

With Loading Footage dialog it's possible to load single files and image sequences as well. An image sequence is a group of files which are consecutively numbered. Image sequences can be expanded into still images.

Press ok after selecting the frame(s) you wish to import. Mewa Film creates a copy of the imported footage so you can move or delete the original footage.

Once the footage finishes being imported it appears at footage window.

Editing footage[edit]

To edit footage we need first to create a montage tab where footage will be edited. We create a montage tab by selecting MontageWindowButton.png in view tool bar. Once the montage tab is created just drag the footage you want to edit from footage window to your montage tab.

Editing footage

Note that by dragging footage from the footage window you are creating a copy of the footage at montage. To edit the footage itself double click the footage item in the footage window. A montage tab with the name of the footage is opened.

Know all you can do with a montage in chapter Editing with Montage.

All operations are undoable. To undo redo use the Edit menu or the buttons UndoButton.png and RedoButton.png in the toolbar.

Creating a node graph[edit]

With the node graph you can apply operations over images and create 3D effects.

We will start creating our node graph by adding footage to our workflow.

Add footage to the node graph

With the Top level tab selected, drag any footage from the footage window and drop it in the node Top level tab. Footage is represented by a footage node in the node graph. Every footage node can be independetly position is time using the timeline. To show the timeline window chose the menu View >> Timeline.

Adding more nodes to the node graph

Nodes, also called tools, are available from the nodes toolbar. Nodes are organized in two main categories,

  • image nodes,
  • and 3D nodes.

Image nodes have green inputs/outputs while 3D nodes have red inputs/outputs. For now we will only use image nodes to introduce the node graph but you can read more about how to use image nodes and 3D nodes in Using the Node Graph chapter.

From the nodes toolbar choose UnderwaterEffect to add the UnderwaterEffect node to the node graph and connect the Footage node to the UnderwaterEffect node has shown in the image above. Our node graph applies a underwater effect to our footage.

Every image node has a button to show it's output image. When clicked a output window pops up, if there isn't one yet, showing the node output. Clicking in the body of a node also makes pop up a window, it's the parameters window, presenting all the modifyable parameters of the node.

Quit the application[edit]

To end your Mewa Film session, select File > Exit Mewa Film in the main window, or click the close icon in the top right corner. Mewa Film displays a confirmation dialog box asking to save the current project before quitting, if not saved yet.



Back to contents page