Inkscape/Print version

From Wikibooks, open books for an open world
< Inkscape
Jump to: navigation, search
Inkscape's logo.

This is a guide to Inkscape--a vector illustration program that is open source and cross-platform. To get help while running Inkscape, choose Help → Tutorials in its menu.


  1. #About
  2. #Introduction
  3. #Interface
  4. #Shape Tools
  5. #Path Drawing Tools
  6. #Other Tools
    1. 25% developed  as of 2008-07-05 #Making a Tomato
    2. #Appendix:Reference
    3. #Glossary



Inkscape is a free open source Scalable Vector Graphics (SVG) editor software program. The creations can be used in web, print and screen design as well as user interface designs, logos, icons, banners and material cutting. Its capabilities are similar to those of commercial products and can be used for any number of pratical reasons such as letterheads, computer and material wallpapers, brochures, business cards and web page designs.

Inkscape's stated goal is to become a powerful graphic tool and being fully compliant with the World Wide Web Consortium's (W3C) Scalable Vector Graphics (SVG) 1.1 standard. As part of this challenge for standard compliance, Inkscape changed its version release notation to reflect its progress of the SVG 1.1 standard and changed its release identification between releases v0.48 and v0.91. The v0.91 reflects that Inkscape is at 82% compliance of the SVG 1.1 standard. While the SVG 1.1 standard compliance is its main goal, other closely related standards are also on the horizon: XML, CSS and HTML5. Most notably, it does not support animations or SVG fonts. As of this writing, Inkscape is at version 0.91.

Inkscape is for Linux, Windows and Mac OS X (under X11), and other Unix-like operating systems. As of 2016, Inkscape is under active development, with new features being added regularly.

Inkscape has good multi-lingual support particularly for complex scripts, something currently lacking in most commercial vector graphics applications.


Inkscape began in 2003 as a fork of the Sodipodi project. Sodipodi, developed since 1999, was itself based on Gill, the work of Raph Levien.

The fork was led by a team of four former Sodipodi developers (Ted Gould, Bryce Harrington, Nathan Hurst, and MenTaLguY) who identified differences over project objectives, openness to third-party contributions, and Scalable Vector Graphics (SVG) compliance as their reasons for forking. Inkscape, they claimed, would seek to focus development on implementing the complete SVG standard, whereas Sodipodi development had emphasized creating a general-purpose vector graphics editor, possibly at the expense of SVG.[1]

Since the fork, Inkscape has, among other things, changed from using the C to C++; changed to the GTK+ toolkit C++ bindings (gtkmm); redesigned the user interface and added a number of new features. Its implementation of the SVG standard has shown gradual improvement, but is still incomplete.

Rather than top-down governance, its developers claim to encourage an equal culture where authority stems from an individual developer's abilities and active involvement in the project. As a result, the project places special emphasis on giving all active developers full access to its source code repository, and on active participation in the larger open source community, often in the form of inter-project initiatives and secondary projects like the Open Clip Art Library[2]. While the project founders are still well-represented in the decision-making process, many newcomers have also come to play prominent roles. Among them is "bulia byak", architect of the profound user interface changes that have given Inkscape its present appearance.

Inkscape is currently a Google Summer of Code and project.[3]


Object creation[edit]

  • Shape tools:
  • Rectangles and Squares (optionally with rounded corners)
  • 3D Boxes
  • Ellipses, Circles and Arcs
  • Stars and Polygons (optionally rounded or randomized)
  • Spirals (inner/outer controls, divergence)
  • Path and Rendering Tools:
  • Pencil tool (freehand drawing w/stroked paths)
  • Bezier Curves and Straight lines
  • Calligraphy tool (freehand drawing with calligraphic objects, graphics tablet pressure/angle support)
  • Text and other tools:
  • Text tool (support for unicode characters (Ctrl+U))
  • Tweak tool (tweak objects by scuplting or painting)
  • Measurement tool (angle and distance viewer)
  • Spray tool (duplicate pre-selected objects by sculpting or painting)
  • Erase tool (erase existing path)
  • Bucket tool (fill bounded areas)
  • Diagram Connector tool, create path diagram connectors (i.e., flow charts, circuit boards)
  • Menu bar rendering:
  • Linked or Embedded bitmap images, either imported or rasterized from selected objects.
  • >Edit>Clones ("live" linked copies of objects)
  • >Extensions>Render (create 18 menu driven objects)
  • >File>Import Open Clipart...(search and download from
  • >Object >Symbols...(Copying and pasting symbols from file being edited and from symbol libraries)
  • >Path >Trace pixel art... (trace an imported pixel image, .png/.jpg)
  • >Extensions >Generate from Path (render 8 menu driven objects based on selected path(s))

Object manipulation[edit]

  • Object transformations (positioning, scaling, rotating, skewing), via freehand, snapped, locked, key combinations, by numeric values or dedicated dialogs (menus)
  • Z-order operations, object stacking order within a layer
  • Grouping objects, with a way to "select in group" without ungrouping, or "enter the group"
  • Layers, with a way to lock and/or hide individual layers, rearrange them, etc; layers form a stacking order
  • Cut, Copy and Paste operations of objects
  • Alignment and Distribution commands, including grid arrange, randomization, unclumping
  • A tool to create patterns of clones, using wallpaper symmetries plus arbitrary scales, shifts, rotates, and color changes, optionally randomized
  • Grid, Guide, Node, Object and other options for snapping

Styling objects[edit]

  • Fill and Stroke dialog (RGB, HSL, CMYK, Color Wheel, CMS)
  • Color palettes
  • Color picker ("dropper") tool
  • Opacity (master, gradient stop)
  • Gradients: multi-point linear and radial
  • Pattern fills (bitmap/vectors)
  • Filters (menu bar, over 260 filters)
  • Mask and Clip effects
  • Dashed strokes, with many predefined dashes
  • Extensions (menu bar, 141 effects)
  • Path Markers (start, middle and end markers, e.g. arrowheads)
  • Copy/Paste styles
  • Per file Swatch

Operations on paths[edit]

  • Node editing: positioning nodes and segments, curve handles, node alignment and distribution, scaling and rotating node groups, "node sculpting" (proportional editing of multiple nodes)
  • Converting to path (for text, images or shapes), including converting stroke to path
  • Boolean operations (union, intersection, difference, exclusion, division)
  • Path simplification, with variable threshold
  • Path insetting and outsetting, including dynamic and linked offset objects
  • Clipping paths (non-destructive clipping)
  • Bitmap tracing (both color and b/w)
  • ‣Path ‣‣Path Effects... contains over a dozen effects that can be manipulated on canvas and via menu settings.
  • ‣Extensions ‣‣Modify Path, to add effects to existing paths and ‣‣Generate from Path for additional operations on paths.

Text Tool[edit]

  • Multi-line text
  • Adjustable font sizes
  • Use of any fonts installed in the Operating System
  • Condensed, Normal, Italic, Italic Condensed, Bold, Bold Italic, Bold Italic Condensed, Heavy
  • Align left, Align center, Align right, Justified (flowed text only)
  • Superscript(s) and Subscript(s)
  • Line spacing, Text spacing, Word spacing, Horizontal character spacing (kerning), Vertical character shift, Character rotation
  • Horizontal text frame, Vertical text frame
  • Unicode character support (Ctrl+U while in the 'Create and Edit Text' tool)
Text Menu bar[edit]
  • Text and Font... (Dialog)
  • SVG Font Editor...(Dialog)
  • Glyphs...(Dialog)
  • Put on path (text and path remain editable)
  • Remove from path
  • Flow into frame
  • Unflow
  • Convert (flowed) to text (retains margins)
  • Remove Manual Kerns
  • Spell Checking...(Dialog)


  • Zoom options
  • Display mode: Normal, No filters, Outline
  • Color mode: Normal, Grayscale
  • Page Grid
  • Guides
  • Show/Hide interface bars
  • Show/Hide Dialogs
  • Swatches...
  • Previous Window
  • Next Window
  • Icon Preview...
  • Duplicate Window
  • Full Screen
  • Default, Custom and Wide

File formats[edit]

  • SVG compliant file generation and editing
  • PNG, OpenDocument Drawing, DXF, sk1, PDF, EPS, PostScript and more export formats
  • Live watching and editing the document tree in the XML editor
  • Command line options for export and conversions


  • Collaborative editing over a network (whiteboard)
  • RDF metadata (authorship, date, license, etc.)
  • Graphic tablet support
  • Extension support
  • User interface is translated in more than 40 languages

Interface and usability[edit]

One of the priorities of the Inkscape project is interface consistency and usability. This includes efforts to follow the GNOME Human Interface Guidelines compliance, universal keyboard accessibility, and convenient on-canvas editing. Inkscape has achieved significant progress in usability since the project started.[4]

The interface of Sodipodi (Inkscape's predecessor) was partly based on those of CorelDRAW and GIMP. The current Inkscape interface has been partially influenced by that of Xara Photo and Graphic Designer.

The number of floating dialog boxes has been reduced, with their functions available using keyboard shortcuts or in the docked toolbars in the editing window. The tool controls bar at the top of the window always displays the controls relevant to the current tool.

All transformations (not only moving but also scaling and rotating) have keyboard shortcuts with consistent modifiers (e.g. Alt transforms by 1 screen pixel at the current zoom, Shift multiplies the transformation by 10, etc.); these keys work on nodes in Node tool as well as on objects in Selector. The most common operations (such as transformations, zooming, z-order) have convenient one-key shortcuts.

Inkscape provides floating/mouse-over tooltips and status bar hints for all buttons, controls, commands, keys, and on-canvas handles. It comes with a complete keyboard and mouse reference (in HTML and SVG) and several interactive tutorials in SVG.


External links[edit]


Scalable Vector Graphics[edit]

Scaling a bitmap and a SVG drawings makes the differences appear.

A vector object is composed of edit enabled path(s) and geometrical elements (nodes) based on two dimensional vector (x/y) coordinate values. This is very different from raster (or bitmap) images, which are composed from a grid (bitmap) of colored squares. Bitmaps are inherently "pixellated" when scaled larger (zoomed in), while vectors can be scaled to any size, and won't display any pixelized objects.

Some graphic editor programs, such as the GIMP, are known as bitmap or raster (photograph) editors. With Inkscape, you can create and edit vector graphics, and save them as Scalable Vector Graphics (SVG) files or 'save as' over 25 graphic editor based file formats. SVG is an open standard designed by the World Wide Web Consortium (W3C), that uses Extensible Markup Language (XML) to create vector based objects.

The Graphic User Interface (GUI)[edit]

When you load Inkscape you will see the main interface:

Inkscape(main window).png

{{print entry|Interface

Shape Tools[edit]


ou will need to know how to draw basic shapes before you can draw more complex shapes. This page will teach you how to draw these shapes. The shape tools are useful because they allow you to make and manipulate basic forms easily.

All shapes have control handles that can be dragged to manipulate various aspects. Sometimes it's better to use the shape's resize handles, instead of the Selector's generic resize abilities. While the Selector resizes relative to the document, the shape tools will resize relative to the object. Experiment with both to see which works best for you. (Use Ctrl+Z to undo any changes you don't want to keep.) To restrain the resize handles, Ctrl+Drag them. This limits movement to 15-degree steps. To change the step size, go to ‣File ‣‣Preferences ‣‣‣Behavior and choose <Steps>.

Rectangles Inkscape icons draw rectangle.svg[edit]

Rectangles and Squares tool

Keyboard Shortcut: R or F4

The Rectangles and Squares tool has a total of four shape handles. The two square handles (☐) control the size (width/height) and the two round handles (⭘) control corner rounding (Rx/Ry).

Hold ctrl while dragging one of the square handles (☐) Ctrl+Drag to create a width to height integer-ratio square or rectangle (e.g. 1:1 square or 3:1 rectangle). Hold shift while dragging a square handle (☐) ⇧ Shift+Drag to draw a square/rectangle from the center out. Hold both ctrl and shift while dragging a square handle (☐) Ctrl+⇧ Shift+Drag to draw a integer-ratio square or rectangle from its center.

To make the corner rounding the same (even) Ctrl+Drag one of the rounding handles (⭘), as the handle is moved from the corner the other rounding handle will move at the same ratio. Another option for rounding is to use the Rx and Ry numeric-value boxes on the Rectangle's Tool Controls bar. To reset the corner rounding use the Rectangle's Tool Controls bar, and click the 'make corners sharp' button, last item on the Tool Controls bar.

For help with the Rectangle and Circle's Tool Controls bar features, mouse-over 🖰 a button or numeric-value box for a pop-up message. You can also Right-Click a numeric-value box for a pop-up menu of pre-set values.

Rectangle: Statusbar highlighting of Tool Tip message

Command keys (Ctrl, Shift and Alt) based Tool-Tip messages can be read at the bottom center of the user interface in the Statusbar. The tool tips are dynamic and will change based on (1) current edit being performed (2) mouse-over 🖰 of one the shape handles (3) press and hold one of the three command keys (Ctrl, Shift and Alt) will update with the associated tool tip, i.e., while in the Rectangles and Squares tool hold the Ctrl key and the tool-tip message will update.

3D Boxes Inkscape icons 3d boxes.svg[edit]

3D tool, with x,y,z shape handles

Keyboard Shortcut: X or ⇧ Shift+F4

The 3D Box tool is an easy way to create a nearly 3-dimensional shape. Inkscape is a two dimensionial x/y vector editor, there is no 'z' axis within Inkscape.

Each dimension can lie on either parallel or converging edit lines. These edit lines are shown in different colors, so that users can distinguish one line from another:

  • red lines reflect the X direction (width);
  • blue lines reflect the Y direction (height);
  • yellow lines reflect the Z direction (depth).

To select only one side of a 3D box, Ctrl+Click it.

Ellipses Inkscape icons draw ellipse.svg[edit]

Ellipse, Circles and Arcs tool

Keyboard shortcut: E or F5

To draw an ellipse, circle, or an arc select the Ellipse Tool, and drag from the top left to the bottom right. The ellipse tool has a total of four handles: two square handles control the size and aspect ratio; two circle handles control the angle of the arc. Mouse-over 🖰 your cursor on one of the square or circle handles and the Statusbar (bottom center) message will update and display the handle's available edits and any Ctrl, ⇧ Shift, and Alt key edits (if available).

Dragging the circle handles outside the ellipse makes a segment (pie chart); dragging them inside creates an arc.  Alt+Click one of the circle handles to completely close the ellipse.

Stars and Polygons Inkscape icons draw polygon star.svg[edit]

Stars and Polygons tool

Keyboard Shortcut: * or ⇧ Shift+F9

To switch between creating a Star and Polygon, click either the star-shaped or polygon-shaped icon in the Tool Controls bar of the Star/Polygon tool.

The Star Tool has two shape handles, one tip (  ⃟  ) handle for tip adjustment, and one base (  ⃟  ) handle for base radius editing. Ctrl+Drag  the tip handle in order to stretch the star without rotating, and Ctrl+Drag  the base handle to change the ratio of the two handles without skewing.

The Polygon Tool only has one shape handle, the single tip (  ⃟  ) handle can be used to lock the tip radius (rotation). Ctrl+Drag  the tip handle in order to resize the polygon without rotating it.  ⇧ Shift+Drag  edits the rounding of the tip handle, while Alt+Drag  will randomize the tip handle.

Spirals Inkscape icons draw spiral.svg[edit]

Spiral tool

Keyboard shortcut: I or F9

The Spiral Tool has two shape handles an outer (◇) handle and an inner (◇) handle. Dragging the handles lengthens and shortens the spiral.

The outer handle can edit the roll/unroll of the spiral, can snap angle, scale, rotate and lock the outer radius. Here are the combination of keys to support the outer handle edits:

  • Ctrl+Drag  the outer handle to roll/unroll spiral and snap angle.
  • ⇧ Shift+Drag  the outer handle to scale and rotate the spiral.
  • Alt+Drag  the outer handle to lock the outer radius.


Alt+Drag  the inner handle to change the divergence (distance between the rolls). To make the distance really big, hold Alt and move the inner handle first towards the center, and then further in the same direction beyond the center.

Spirals with a divergence less than 1 are denser towards the edges; ones with divergence greater than 1 are denser towards the center. To reset divergence, Alt+Click  the handle. ⇧ Shift+Click  the handle to return it to the center.

Experiment with the handles and the ⇧ Shift and Alt keys to get a grip on the tool.

Fill and Stroke Fill and Stroke dialogue[edit]

Fill and Stroke dialogue

Keyboard shortcut: Ctrl+⇧ Shift+F

All objects (shapes, paths and text) have a fill and stroke styles. The stroke is the outline of the object, and fill is the area inside the object.

To set fill and stroke styles, Select the object and go to Object ‣‣Fill and Stroke... or press Ctrl +Shift + . The Fill and Stroke dialog has three tabs labelled Fill, Stroke paint and Stroke style.

An objects fill can be set to empty, flat color, linear or radial gradient, pattern, swatch, unset, self-intersections and solid.

The Stroke style edits include:

  • Width with unit of measure (i.e, pix, pt, cm, inch...)
  • Join (corners); Miter, Round, Bevel
    • Miter maximum length of the Miter join
  • Caps (end points) Butt, Round, Square
  • Dashes (stroke patterns) and Offset
  • Markers for Start, Mid and End (nodes). Text objects only have the stroke's "Width with unit of measure" edit available.

Color models provided by Inkscape (v0.91) include RGB, HSL, CMYK, Wheel and CMS. When working with the Filters menu, if you come across a filter that seems to have no impact on the object. First remove the filter from the object, ‣Filters ‣‣Remove Filters (Alt+S, R. Open the Fill and Stroke Menu and use the HSL (hue, saturation, and lightness (or luminosity)) model tab, then under the lightness (L) setting try middle 128 to high 255 values. Some of the filters are dependent upon an object's lightness and when an object is too dark the filters seems to not work correctly.

Contrasting (opposite) colors are very easy to select when using the Color Wheel. The color wheel has two edit icons, one lies on the outer wheel and is a straight line, the other edit icon is a circle that lies within the inner triangle. The triangle has 3 main color edit corners, the corners are full white, full black and full color (no white/black). The inner triangle circle edit (position) sets the color's darkness, lightness or neutrality (middle of triangle).

Blur and Opacity, posted at the bottom of the fill and Stroke dialogue are two often overlooked edits, these two color edits impact both the fill and the stroke. The Blur % edit provides 0.0 based increments from 0.0 to 100.0, with a default of 0.0. When working with blurs it is a good idea to set the Zoom to 100% (1). The Opacity (transparency) setting is similar to the color models "Alpha" setting, the difference is that the Opacity is applied to the entire (fill/stroke) object. A setting of 0% and the color is completely gone. One of the most used 0% settings is in the default creation of gradients, one gradient stop at Opacity 100% (full color) and the other stop set to no color (Opacity 0%).

Having trouble with an objects coloring? Open this dialogue and look at three edits Blur, Opacity the Alpha settings. The alpha setting is common among all of the color models (i.e., RGB, HSL, CMS, etc...). During some, not all, of the thousands of color edits a given object's fill and or stroke will have a alpha value or opacity % of 0 assigned. Going to this menu allows one to see both the alpha (fill or stroke) opacity (fill and stroke) settings under one dialogue and set them to 255 (alpha) and 100% (opacity).

Path Drawing Tools[edit]


aths can be created by Path Tools, Pencil, Bezier, and Calligraphy, rendering and object conversions. Rendering of pre-configuured objects can be created using the ‣Extensions <Render> Menu bar features. Converting an existing shape or text object to a path, can also create paths:

  • Path ‣‣Object to path
  • Path ‣‣Stroke to path

Unlike the use of shape handles for editing, path objects use three types of path nodes. The start/end and corner(s) of a path are referred to as Cusp Nodes nodes along a path. A path's curve settings are provided by two types of Smooth Nodes, smooth and auto-smooth Nodes . Smooth nodes can have one straight segment and one curved segment on either side of the node. The Cusp and Smooth Nodes have handles that are used to set the node's length (x,y value of the handle itself) its angle and distance, the 'tool-tip message' in the Status Bar displays this dynamic information. Spiro based paths do not respond to node handle positioning edits and if the handles are retracted for auto-smooth nodes, the node will change to either a smooth or cusp node.

There are thin red lines between path nodes and are used to edit a 'segment' between two nodes. To view the red line segment editing, you must change from the Path Tool (P, B and C) to the Node Tool (N). When you mouse-over 🖰 a segment the Node Tool cursor changes to a pointer with a fist. This segment editor can also change a segment from a curve to a straight line or vice versa. Once a segment is selected (clicked) the two adjacent path nodes change color and the edit is applied by either dragging the segment or using the Tools Controls bar edits. The Tool Controls bar can be used for many edits; change selected segment(s) to a line; change selected segment(s) curves; delete the segment between two non-end points. This segment based editing also impacts the editing of Spiro paths.

The default stroke, fill and Ctrl+Click settings of the tools can be set using:

  • Edit ‣‣Preferences <Pencil>, <Bezier> and <Calligraphy> settings.
Inkscape icons draw freehand.svg Pencil tool
Inkscape icons draw path.svg Bezier curve and Straight line tool
Inkscape icons draw calligraphic.svg Calligraphy tool

Pencil Tool - Bezier (Freehand) Inkscape icons draw freehand.svg Pencil Tool Mode Bezier Icon v091.svg[edit]

Pencil Tool:
1.) Set to Bezier (Freehand) Mode

Keyboard shortcut: P or F6

The Pencil Tool creates two styles of a path and dots (circle shapes). The first (default) option creates freehand Bezier curves and lines. Freehand drawing can be done in two ways. (1) By dragging (press+hold) the mouse 🖰 on the canvas. (2) By a series of Clicks and Releases, example Click on the canvas (don't drag) then move the cursor to another location and Click again this will create a path segment. Additional segments can be added to the first segment, by clicking on one of the end nodes. This Click-Release method is helpful when creating Spiro paths.

Once a path is created, there are three options for editing the path nodes. (1) To reduce the number of nodes on a given path use the path simplify command; Path ‣‣Simplify (Ctrl+L). (2) To add nodes to an existing path place the mouse cursor 🖰 over a start/end node, the node will change color left click and either drag or click to another position on the canvas. (3) Once a path is created the Node Tool can edit the nodes, it has an extensive set of node and segment editing features, available in the Tool Controls bar.

Pencil Tool - Spiros Inkscape icons draw freehand.svg Inkscape Pencil Tool Mode Spiro Icon v091.svg[edit]

Pencil Tool:
2.) Set to Spiro Mode

Keyboard shortcut: P or F6

The second mode of editing, enabled by using the Tool Controls bar, creates a Spiro based path which involves both cusp and smooth nodes . Smooth nodes apply spiro based interconnection to adjacent nodes within the path. Once the spiro path is created, the Node Tool must be used to edit the positioning of the spiro's smooth and cusp nodes. Even though smooth node handles are displayed on Spiro paths they do not impact editing of the Spiro. The positioning (vector) of smooth nodes in relation to adjacent cusp/smooth nodes is how a spiro's rendering is calculated. The thin red line segment editor can be used to set a straight or curved segment within a spiro.

Note - The pencil tool's spiro rendering is based on the Smooth setting of the Tool Controls bar. Smoothing is how much path simplifying nodes are applied to the spiro being created. If smoothing is set too low, there will be no effect (vector distance between nodes dependant), set to high and the smoothness will render a straight line.

Pencil Tool - Dots (Circle Shapes)[edit]

3.) Creating Dots, using command keys

The pencil tool can also create single dots (circle shapes), using command keys;

  • Ctrl+L-Click creates a dot shape
  • Ctrl+⇧ Shift+L-Click creates a dot twice the size of the
    Ctrl+L-Click dot
  • Ctrl+⇧ Shift+Alt+L-Click creates a random radius dot

Once the dot is created, the editing is now changed over to the Ellipse Tool. The dot radius can be set in the Preferences of the pencil tool, Edit ‣‣Preferences <Tools> <<Pencil>> (Ctrl+⇧ Shift+P) "Ctrl+Click radius setting: xox times current stroke width".

This dot creation can be used as a work-around for creating text bullets, as of Inkscape v0.91 there is no internal support, other than Unicode values, for bullets in any native Text formatting.

Bezier Curve tool Inkscape icons draw path.svg[edit]

Keyboard shortcuts: B or ⇧ Shift+F6


Above is an example of a bezier curve. You can see two nodes in this view. These are the start and end nodes of the curve. But there are path nodes with control handles that you cannot see. These determine how the line curves between the end nodes. In order to view and edit path (stroke) nodes you will need to click on the Node tool button (N}.

Node tool Inkscape icons edit nodes.svg[edit]

Keyboard shortcuts: N or F2


Clicking on the node tool reveals another node in the middle of the curve.

If you then click on the middle node you will see the bezier handles appear.


These handles allow you to change the shape of the curves between the nodes. Notice that a list of node tools appear at the top. You can use these to change the nodes. We will not go into detail about these tools in this beginners tutorial.

The node tool can be used on all the objects created with the other tools to reveal their nodes.

More on the drawing tools[edit]

The other two drawing tools also create paths. The top tool of the three is the scribble tool Inkscape icons draw freehand.svg. Use it like a pencil. The computer will calculate all the nodes and beziers for you. Closed paths can be created by drawing a loop. (With the bezier toolInkscape icons draw path.svg, click on the start node to close the curve).

The last tool in the group is the calligraphy toolInkscape icons draw calligraphic.svg. It allows you to do calligraphic writing. The pen creates closed loops in a realistic pen nib like way. Because of this many graphic artists like to draw with this pen all the time.


Other Tools[edit]


To do:
Created by taking over from [1]. Needs to be rewritten; a beginning transition is missing.

Selection tool Inkscape icons tool pointer.svg[edit]

Keyboard shortcuts: S or F1 or Spacebar

This tool allows you to select objects, resize them and move them about. If you click twice on an object with the selection tool, the handles change and you are able to rotate an object. Click a third time to switch to the object's tool.


Node tool[edit]

Keyboard shortcuts: N or F2


To do:
This topic needs attention

Tweak tool[edit]


To do:
This topic needs attention

Zoom tool Inkscape icons sticky zoom.svg[edit]

Keyboard Shortcuts: Q Quick Zoom, Z or F3

Drag the tool over a given area to zoom in. ⇧ Shift+Left click  to zoom out again. You can zoom in and out with the + and - keys, respectively.

Other shortcuts to zoom in are:

  • Ctrl+Middle click 
  • Ctrl+Right click 

Shortcuts to zoom out are:

  • Ctrl+⇧ Shift+Middle click
  • Ctrl+⇧ Shift+Right click

Inkscape keeps a history of your zoom levels. For a 'Previous' zoom level, use `; for the 'Next' zoom level, use ⇧ Shift+`.

Measurement Tool[edit]


To do:
This topic needs attention

Text tool Inkscape icons draw text.svg[edit]

Keyboard Shortcuts: T or F8

Click and Drag an area where you want your text to go, then start typing! If the letters are too small, open on the Select tool F1, then drag the handles to make it bigger. There are a lot of things that you can do with text that are beyond the scope of this beginners tutorial.

Spray tool[edit]


To do:
This topic needs attention

Erase tool[edit]


To do:
This topic needs attention

Paint bucket tool[edit]


To do:
This topic needs attention

Gradient tool Inkscape icons color gradient.svg[edit]

Keyboard Shortcut: G or Ctrl+F1

Click the Gradient tool button in the Inkscape tool bar, then Click+Drag on an object and you will create a gradient from a fully opaque colour to full transparency. The gradient tool can be used to edit an existing gradient, adjust colour stops by dragging and placing the gradient handles that appear over an object when the tool is active.

The Gradient tools Control bar (3rd bar from the top of the Inkscape GUI) is how to select the following beginner edits:

  • Linear gradient
  • Radial gradient
  • Apply gradient to fill
  • Apply gradient to stroke
  • Select edit to preset gradients

Color Picker tool Inkscape icons color picker.svg[edit]

Keyboard Shortcuts: D or F7

The Color Picker, or "eyedropper" tool can be used to sample any colour in the Inkscape canvas. One of the key reasons for this tool's use is to enable the picking of colors from an image. First import Ctrl+I the image into Inkscape and then use this tool to pick a colour setting from the image to the selected object, beginner options listed:

  • Click to set fill
  • ⇧ Shift+Click to set stroke
  • Drag to set average color of area
  • Alt Click to pick inverse color

Connector tool Inkscape icons draw connector.svg[edit]

Keyboard Shortcut: O

Use this to draw a connection between two objects. For example, a drawing and a label.


The nice thing about using this tool is that if you decide to move the objects about on the canvas, the connector still maintains the connection. As of v0.91, once the connector is created and rendered onto the canvas, if you drag only the path it will 'disconnect' itself from the objects it was attached to.

Making a Tomato[edit]

We want to make a juicy and plump tomato. Mouthwatering to look at, we really want to bring our product to life.

A tomato.

NOTE:In some versions SHIFT + CRTL + F is replaced by CRTL + ALT + F to access the attributes of an object

  1. Using the Circle tool draw a circle on the page
  2. With the circle selected, press SHIFT + CRTL + F to go to its attributes
  3. Change the Opacity to 80%
  4. Change the colour to a nice tomato red
  5. With the circle tool again, draw an ellipse, the same width as the tomato, below the tomato, this will be our shadow
  6. With the ellipse selected, press SHIFT + CRTL + F
  7. Change the blur to 20%, you can check the results as you move the slider.
  8. To add the leaves, select the calligraphy tool and change the colour to green
  9. In the calligraphy tool, change the Thinning attribute to 0.90
  10. Scribble the leaves on, if you aren't satisfied, delete them and try again.
  11. select the main body of the tomato and press CTRL + D, this will make an exact copy of the tomato directly over the original
  12. Select this new copy and press SHIFT + CRTL + F
  13. Change the Alpha channel to 50%
  14. Change the colour to white, you should now have a hazy looking tomato
  15. select the 'haze' and press CTRL + SHIFT + C, this will change the haze from being a circle to allow you to change its shape more vigorously
  16. With the Node editing tool select the haze and using the square handles crop the haze to look like a reflection. If you want to add more square handles to the haze just double click.
  17. Sit back and admire your work



Shortcut Description
Ctrl+Z Undo (can be done multiple times)
Ctrl+Y or
Ctrl+⇧ Shift+Z
Redo (can be done multiple times)
Ctrl+B Hide/show scrollbars
Ctrl+ Scroll
⇧ Shift+Mouse wheel Scroll horizontally
Ctrl+Tab ↹ Cycle through Inkscape windows
Ctrl+⇧ Shift+Tab ↹ Cycle backwards through Inkscape windows
- Zoom out
+ Zoom in
Ctrl+Middle click / Right click Zoom in
⇧ Shift+Middle click / Right click Zoom out
Ctrl+Mouse wheel Zoom in (up) or out (down)


This is the glossary which includes terms within the book that are either newly introduced, uncommon, or specialized.

Contents: Top - 0–9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


In graphics, 3-D (three dimensions) describes an object that provides a visual sense of depth. The open source software Blender is a 3-D based graphic editor.


Access Keys

An access key is an alphanumeric key—sometimes called a hot key that users can use instead of a pointing device (mouse cursor) to activate interactive commands. With a few standard exceptions, an access key interacts to a underlined character in a control title (label). For example, to open the File menu, for which the access key is typically F, the user would press ALT+F. Access keys are associated only with controls that have text titles (labels).[1]

In computer graphics, Alpha combining is the process of merging a foreground (top) object with a background (bottom) object to create the appearance of partial or full transparency. Inkscape applies Alpha values to an object's fill and stroke seperately.[2]
Lines up selected objects, basic aligments are typically horizontal (x) or vertical (y). The Snap Controls bar has 15 different snap modes which provide far beyond basic alignments.


For text, the baseline is where most characters (i.e., "x/z") rest. Some characters like "j/q" go below the baseline. By default Inkscape aligns characters to a common baseline. The baseline icon is a very small square at the bottom left corner (default) of the bounding box when the text object is selected.
Bézier curve 
A Bézier curve is a math defined curve used in two-dimensional (x/y) graphic applications. The curve is defined by four vector based positions: the start position and the end position ("cusp nodes" in Inkscape) and two separate middle points ("node handles" in Inkscape). The shape of a Bézier curve can be changed by; (1) moving the node handles (2) dragging the path segment between the two cusp nodes.[2]
A bitmap is a display space and the color for each pixel or "bit" in the display space. GIF, JPEG and PNG are examples of graphic image file types that are based on bit maps. Because a bit map uses a fixed or raster graphics method of specifying an image, the image cannot have its size scaled larger without losing sharpness. A vector graphic is designed to be rescaled without any impact on the graphics sharpness. Vector graphics are being used more due the lossless nature of the file and are considered a compliment to bitmap editors. Many websites use a combination of vector graphics and bitmap images.
Are websites that provide information on many topics, and that are allowed by the hosting provider. Blog postings are published in reverse dated order and sometimes allow readers to post comments and ratings. Here is an example link (2016) to an Inkscape Blog.
Bounding Box 
Is a rectangular box border around an object or multiple selected objects (shape, paths or text) that can be moved (dragged), flipped, rotated, skewed or scaled. Most graphic editors use either dashed or dotted lines to mark the bound box.
In the Inkscape Graphic User Interface (GUI), a button starts an action when it is clicked. A button that is grayed out is not available due to no object selection or a disabled/unavailable edit based on the selected object(s).


is made up of two partnered, sub-paths which make variable height nodes. This allows the resulting line to have a variable heights, the fill is solid with no stroke coloring.
The Canvas area is where objects are created, centered within the canvas there is a page area. Some artist create their objects in the canvas area before moving them into the page area.
Cascading Style Sheets (CSS) 
Check boxes 
Clipping objects uses any combination of ‘path’, ‘text’ and 'shapes' to serve as the upper outline, where everything "below" and on the "inside" of the upper outline is allowed to show through but everything on the outside is cut away and not shown. While images can be a lower item and clipped, images cannot be the topmost item and set a clip of a lower object.[3]
CMYK (cyan, magenta, yellow, key) 
A line connecting two objects, one which sticks to them even when the objects are moved.


dpi (dots per inch)
1) In computer monitors, dots per inch (dpi) is the amount of sharpness of an object. The dpi for a given image (photograph) sharpness will lower when displayed on a larger monitor. By some users the term "dots per inch" is used for image sharpness from printers, and is replaced by the term "pixels per inch (ppi)" for monitor sharpness.
2) In personal home printing, dots per inch (dpi) is the usual sharpness for images on paper. Most home printers print up to 600dpi, for higher quality image (photograph) printing is done at a commercial print store.
Drop Shadow 
Is an effect where an object is repeated behind itself to create the illusion that the object is floating over the background.
Duotone (a.k.a. Twotone) 
A duotone is an object made up of two colors. A duotone is created by placing a less than (<) 100% opacity, two color (i.e. green and red) object on top of a grayscale object/background.[2]


An emoji (a.k.a. emoticon) is a small image that refers to a facial expression, an activity, an idea and even more items. The Text tool can create emojis using Unicode values.[4] While in the text tool enter the following:
  • Ctrl+U, then type 1F600, and press ↵ Enter (watch the Statusbar notification area) and a smile emoji 😀 character will be created, have fun!
Extensions (Extras)
Inkscape currently provides a majority of its extensions with python scripts, the scripts add features to the software.[5] Types of extensions that currently exist for Inkscape (v0.91):
  • Input (read a file/data)
  • Output (write a file/data)
  • Effect (change contents in the file/document)
  • Print (output to an external device)


Filters are special effects that can be applied to an image or object. Filters can vary from real simple to very complex. Inkscape has hundreds of filters, some of the more complex filters will display a sub-menu to increase its ease of use.[2]
The painting the inside of an object or the inside of the characters in a text string.
Flat Design 
A font is a set of text characters with specific styles and sizes. The type design for a font set is referred to as the typeface, variations of this type design form a typeface family.[2]
An example;
Arial is a typeface family, Arial italic is a typeface, which leads to a Arial italic 10-point font (set). So when someone asks "What font is that? the reply should be "Its Arial italic at 10 points."


GIF (Graphics Interface Format) 
Is a 1987 patented compression standard for bitmap graphics, and is supported by the majority of web browsers. GIF Version89a (1989) added background transparency, metadata and enhanced the animation feature, which is a sequence of bitmaps within a single GIF file.[2][6]
GIMP (GNU Image Manipulation Program) 
Is a feature rich, open source application for creating and manipulating graphic images (photos) that runs on Linux, Unix-based operating systems, Windows and Mac OS X
A glyph represents a unit of rendered (to display, show) content within a font. Often, there is a one-to-one match between characters to be drawn and matching glyphs (e.g., often, the character "A" is rendered using a single glyph). But other times multiple glyphs are used to render a single character (e.g., use of accents é) or a single glyph can be used to render multiple characters (e.g., ligatures). A ligature occurs where two or more characters are joined as a single glyph. The & (ampersand) glyph was originally formed from the combination of the two letters E and t &.
A grid is an arrangment made from a series of intersecting (criss-crossing) straight; vertical, horizontal, and angled lines used to organize the placement and measurement of objects. The grid serves as a framework to assist the user in the organizition of multiple graphic items (images, shapes, text, paragraphs, etc.) in an ease-of-use method.
Guides (a.k.a. Guidelines) help with the alignment settings of text and objects. The placement of guides are all user defined, unlike grids which uses pre-defined placement and is universal to the file. Like grids, guides do not print.
A gradient is a gradual mix of colors and of a single color from a 100% opaque (full) to 0% (no color). It is also good way to create a smooth color change across one or more objects.


A small rectangle or circle that enables the user to control shape handles. While Shapes have handles in Inkscape, Path nodes also have handles and are referred to as node handles.
Help (Assistance) 
HSL (Hue Saturation Lightness)
HSL is a color model for managing colors under the labels of:
  • Hue - rainbow of colors range (no black, white, and gray)
  • Saturation - gray depth/intensity range to Hue (full) color.
  • Lightness - range from black (0) to pure color (128) to white (255).(1)

(1) Most graphic software providers use a numeric-value range of 0 to 255 for HSL settings, and was used as an example to show the Lightness values from black to full color to white.


An illustration is a decoration, clarification or visual explanation of a text, concept or process, designed for placement in published media, such as posters, flyers, magazines, books, teaching materials, animations, video games and films.
Inverse Color
Is the opposite of another color, also referred to as contrasting colors. The Color Wheel color model is a simple way to find an inverse color. Here are a couple of inverse colors:
White is the inverse color of black.
Blue is the inverse color of yellow.
Icons are symbols that appear on most software application user interfaces and are used to graphically represent a command. A common example is a scissor symbol ✂ to represent cutting (removing) an object.


JPEG (Joint Photographic Experts Group) 
JPEG (often pronounced jaypeg) file format is specified in ISO standard 10918, the standard includes 29 distinct coding processes, with compression being one of its key features. Not all JPEG capable application use all 29 codings. Together with the Graphic Interchange Format (GIF) and Portable Network Graphics (PNG) file formats, JPEG is one of the image file formats supported on the World Wide Web, usually with the file suffix of ".jpg".


Is how the position of characters in text boxes are changed. The character position changes, help increase the appearance of the text. Here are a few letter combinations (To) (ff) (WA) (AV) that sometimes need kerning adjustments.
Left default character position, right after kerning edit
The kerning example graphic shows how kerning is also helpful when using multiple fonts in the same text box.


In graphic applications a layer is a way of organizing complicated and many objects in a file. Imagine a set of objects stacked on top of each other. If you want to make a change to one of the lower items, it will take alot of object moving and may lead to alot of boredom. Here is an example of how to use layers. The bottom layer is be the background color of a web banner. The layer above the background may have objects that decorate the banners edges, like flowers or shooting stars. The layer above the decorations may have text, like a slogan or motto. And the highest layer may have a logo or image. Placing related objects in their own layer is useful because they allow you to lock/unlock and view/hide layers you are not currently working on. Once your are done editing items in a layer, you can lock (no editing) it, but you still want to view (not hide) the items in the layer. So when you are working the decorations layer the other layers are viewable, but locked so there is no risk of accidently changing an item in another layer. The more complex the graphic, the more layers should be used.
Lorem Ipsum 
Creates an effect string of filler text that displays Latin characters. It is used as a place holder for text dependant publications like the front page of a newspaper, slide show and a flyer. This effect assist the artist as it allows the creation of graphics involved in desktop publishing, without having to 'wait' on actual text to complete the graphic design portion of the file. Flowed text is another compliment edit for the Lorem Ipsum effect/extension.
Lossless compression is a term that describes the compression of a file. All of the original data is untouched when the file is uncompressed. The GIF image file is a format that uses lossless compression.
The opposite of lossless is lossy compression which reduces a file by permanently removing some of its data. When the file is uncompressed not all the original data is restored. The JPEG image file, used for photographs and other images, has edit based lossy compression. That can make a trade-off between file size and image quality when the compression rate is set.


Menu bar 
Menu types 
Drop Down menus : TO DO
Popup menus : TO DO
sub-menus : TO DO
Mouseover (a.k.a. Hover, Rollover)
Is is a graphical feedback item that is activated when the user moves or "hovers" the pointer over a software's user interface buttons (icons), numeric-value boxes and other software graphics (guides, snapping, etc) all referred to as trigger items. Once a user interface item is triggered by a mouseover, it will provide feedback by generating a button tooltip. The tip should provide a short, easy to understand description of the button's feature and its assigned shortcut key.


A point on a path or shape at which the path or shape can be changed.
Notification Display Area 
Numeric-value boxes 


Openclipart Library
OpenDyslexic Font 
OpenDyslexic is a open source font created to increase readability for readers with dyslexia. The typeface includes regular, bold, italic, and bold-italic styles. OpenDyslexic is free for Commercial and Personal use. [7]


PNG (Portable Network Graphics) 


Rectangular Coordinates 
Rollover (a.k.a. Mouse-over) 
RGB (Red Green Blue) 


Scalable Font 
Screen Captures (Screen Shots) 
Spin Boxes 
SVG (Scalable Vector Graphics) 


Text Styling 




WYSIWYG (What You See Is What You Get) 


X and Y Coordinates 
XML (Extensible Markup Language) 
XML Editor 




See also[edit]


Official links[edit]

Manual links[edit]

Tutorial links[edit]

Graphic links[edit]

Texture links[edit]


Editor's note
Both GNU GPL V2 and GNU GPL V3 are incompatible with GNU FDL. Thus, the materials linked to licensed under either version cannot be taken over to Wikibooks.

  1. Library at
  2. a b c d e f Multimedia-Graphics at
  3. W3C SVG 1.1
  4. Emoji chart at
  5. Extensions at
  6. Homepage of
  7. Open source Dyslexia font at