Informatics Practices for Class XI (CBSE)/OpenOffice Writer

From Wikibooks, open books for an open world
< Informatics Practices for Class XI (CBSE)
Jump to: navigation, search
OOo Writer

OpenOffice.org's Writer is a very useful word processor. It is quickly becoming the standard for word processing. Writer's native file format is .odt, which is an open document format (Older versions of OOo used the native format .sxw). Saving in native format is always recommended even if you're planning to save it to another Office format like Word's .doc format, because this ensures that no formatting would be lost because of .doc's inability to save certain formatting elements. (more about Open Document Format)

Tutorials[edit]

Your First Document[edit]

Open OpenOffice Writer. In Windows you can do this from the taskbar (if you set up quickstarter during install) or its program group. To open from the quickstarter right-click on the icon and select "Writer". In Linux you can usually open it from the OpenOffice Writer Icon on the taskbar or dock, from its entry in your "start" menu, or with the shell command "openoffice -writer &".

Type "Hello World" and save. To save click on the disk icon or go File > Save As... Save the document as hello.odt (if you are using 2.0.0 or 1.1.5) or hello.sxw (if you are using an older version). Don't worry about the extension. Just type the name you want and OpenOffice will automatically use its default extension. We will go over saving in different extensions later.

You have just completed your first document. That was easy, but OpenOffice writer has so much more to offer. Want to do more? Let's turn this document into an Adobe PDF file, a common method of distributing printed material over the internet.

Your First PDF[edit]

Open your first document, and check to make sure that you have a PDF viewer installed on your computer (you can download one from Adobe if you don't have one). You should have your document with "Hello World" written in it. Now go to File > Export as PDF... and it should come up with the same window as before. Title it hello again, and click on "Save". This will bring up the PDF Options window, and for now, all you'll need to press is "Export".

Export dialog

The various PDF Options are:

  • Range - Select either "All", "Pages", or (if you have highlighted certain text) "Selection". This allows you to choose which pages to export as a PDF, usually all of them.
  • Images - Informs OpenOffice.org how you want images compressed into PDF format. "Lossless compression" will be the best quality, but also the largest. "JPEG compression" produces lossy results, and it's according "Quality" option decides how 'liberally' the compression occurs. The "Reduce image resolution" brings the images DPI (Dots Per Inch) down, which could have an effect if the user zooms into an image, making it more pixelated.
  • General - The "Tagged PDF" option produces a text document that is tagged, IE readable by screen readers for the disabled. To produce a properly formatted tagged PDF, you will have to use the internal stylizing of OOo, and not just concentrate on visual output. There is also "Export Notes", which includes the notes on the document in the PDF while exporting. If you use transitional effects in your document, you can choose whether to leave them intact or not by checking the "Use transition effects" option. "Submit forms in format" only decides how the forms for the document will be formatted.

To learn more about PDF formatting and documentation options, look up the PDF Wikipedia entry.

Saving[edit]

saving a document for the first time

  1. Open openoffice writer, and the program starts.
  2. Click on the menu "File" , afterwards click on "Save as"
  3. Type a filename, in this example "tree"
  4. Hit the "save" button

checking which toolbars are enabled

  1. Click on the menu "View", afterwards click on "Toolbars", afterwards click on "Standard" (if it isn't already checked).

Basic Formatting Options[edit]

If you've used Microsoft Word, or any of most other modern word processing programs, you will have no trouble with making basic formatting changes, such as in changing fonts or changing color. To change the formatting, you'll have to block the texts that you want to format, then click on the appropriate formatting buttons.

The formatting toolbar contains most of the formatting options needed for day-to-day usage.

The formatting toolbar. If you can't find the toolbar, go to View > Toolbar > Formatting

Let's talk about things inside the formatting toolbar one by one. Tip: You can hover your mouse on the buttons on Open Office to know what each button do.

Style Control[edit]

OOo - FormattingToolbar - SnF.png

The leftmost button, is the Styles and Formatting Button. Click on it to show the Style and Formatting dialog. Next to it is a Style dropdown menu, which is basically a list of commonly used styles. Styles are basically predefined formatting, which you can apply on a section of text. Style is also used to determine the structure of your writing. The great thing about using style is that if you change the formatting of a style, all elements in your document that previously applied that style would reflect the formatting change, saving you lots of time from changing them one by one. For now, just digest that, we'll talk more about styling in a moment, after we've finished with the toolbar.

Font Controls[edit]

OOo - FormattingToolbar - FontCtrl.png

The next two dropdown menus are for controlling Font Name (or Font Type or Font Face) and Font Size respectively. The Font Name dropdown, controls the type of font used whether it is Times New Roman, Arial, Courier New, or some other fonts you might have in your computer. The Font Size dropdown, as it says, controls how big or how small your text looks like.

Standard Formatting Options (BIU)[edit]

OOo - FormattingToolbar - BIU.png

The next three buttons might be familiar. They are the friendly Bold, Italic, and Underline buttons. If you've gotten more comfortable with OpenOffice, you can also use the shortcuts Ctrl+B, Ctrl+I, and Ctrl+U for Bold, Italic, and Underline respectively. You can also mix these formatting together, forming something like BoldedItalic, BoldedUnderline, ItalizedUnderline, BoldedItalizedUnderlined, etc.

Paragraph Alignment[edit]

OOo - FormattingToolbar - Align.png

Ok, now on to the next section. The next four buttons control the text alignment. There are four types of alignment:

Align Left[edit]

OOo - FormattingToolbar - AlignLeft.png

"Align left" ensures that your paragraphs' leftmost words form a line on the left side of the paragraph. This is the most used alignment, and thus the default alignment for a new blank document. The example of align left is this paragraph. You'll see that the leftmost words make a straight line, while the rightmost words are jagged.

Centered[edit]

OOo - FormattingToolbar - AlignCenter.png

A centered paragraph ensures that your paragraph would appear in the center. This is usually used for titles. You'll see that the length of the leftmost word to the left margin is equal to the length of the rightmost word to the right margin. This paragraph is an example of centered paragraph.

Align Right[edit]

OOo - FormattingToolbar - AlignRight.png

Align right ensures that your paragraphs' rightmost words form a line on the right side of the paragraph. This is usually used for signatures. The example of align right is this paragraph. You'll see that the rightmost words make a straight line, while the leftmost words are left uncontrolled as it fits.

Justified[edit]

OOo - FormattingToolbar - AlignJustify.png

Justify paragraphs is a combination of align right and align left. A "justified paragraph" would make the leftmost and the rightmost words make a line. To achieve this the spacings between the words or the character are usually adjusted. This is usually used to write in small columns, where the use of align left would make the columns look ugly. This paragraph is the example of justified paragraph.

Bullets and Numbering[edit]

OOo - FormattingToolbar - BnN.png

The next two buttons, the Bullets and the Numberings button are for creating lists. If you click the Bullets button, a small circle would show up on the start of the paragraph your cursor is in, or on the start of each paragraph you're blocking. The same for Numbering, although a number would show up instead of circle.

Finer control for making bullets and numbering can be found on the Bullet and Numbering Toolbar that would show up whenever your cursor is in a bulleted or numbered list. Feel free to explore what each of the buttons on the toolbar do.

There are also various collections of Bullets and Numbering style in Format > Bullets and Numbering. Here, you can change the bullets and numbering into Roman Number, for example, or into alphabetical instead of plain number, or even a mix of them. You could even control more in depth by changing the settings on the Position Tab and/or Options Tab.

Indentation[edit]

OOo - FormattingToolbar - Indent.png
The next two button controls the Indentation, the first button move the indent to the left, while the second button would move it to the right. Indenting a paragraph would make your paragraph written deeper into the paragraph or nearer to the paper's edge. You can also move the indentation marker on the ruler for finer movement. This paragraph, for example is indented.

Color Control[edit]

OOo - FormattingToolbar - Color.png

The last three buttons give you full control for colors. The first button would change the font color, like this red text, the second button would highlight the text, like this cyan highlighted text, and the last button would change the background color, like this yellow-background paragraph. There are big differences between highlighting and background color, when changing the background color, you must change the background of the whole paragraph, while highlighting gives you more control for only highlighting certain part of the paragraph.


Shifting Case of letters[edit]

Say you have a sentence "the quick brown fox" and you wish to change it to "THE QUICK BROWN FOX" without retyping it, that is to shift it from lower case to upper case. Writer provides a quick way to do this by shifting the case of a highlighted selection. Just highlight the selection of text you want to shift the case of then right click on that text and in the right click menu select "case/characters" and then select Upper case to make every letter in your selction capital or lower case to make it all lower case.

The Stylist[edit]

If you write longer texts, however, you will quickly discover that manually assigning formatting attributes to text can be a tedious task. It's hard to keep over fifty citations or some twenty Headings in exactly the same font face, font size, character spacing and so on. Thankfully, Writer has a tool to help you keep everything clean, simple and consistent.

The Stylist is a small box that contains lots of predefined formatting styles like "Default" or "Heading 1". Let's work on the following example and use the stylist to touch up this chapter in Writer.

Preparation[edit]

To do this, we first need to copy this text to Writer, which is very easy using the clipboard. If you did not use the clipboard yet, just do the following: Select the text of this chapter, by positioning the mouse cursor at the start of the chapter, right before the heading ("The Stylist"), then hold down the left mouse button and drag the mouse to the end of the chapter. The selected text becomes highlighted, indicating that whatever we decide to do now will influence this part of our document. Next we click on Edit > Copy to place the selected text in the clipboard. To insert this text in Writer, we click in our document where we want to insert the example text, then choose Edit > Paste. If everything went correctly, we will now have quite some text to work with. Now let's see what the Stylist can do for us.

Applying Styles[edit]

If you cannot see the Stylist yet, either choose Format > Styles and Formatting or simply press F11. Among others categories, Writer differentiates between paragraph styles and character styles. We want to apply a paragraph style, so the default category, "Paragraph Styles" selected in the little toolbar at the top of the Stylist is just right.

Let's make the text a little easier to read and indent the first line of some paragraphs. To do this, we click somewhere in a paragraph that we want to apply a the new style to, then choose and double click the "First line indent" style. If everything worked alright, the first line of the selected paragraph is now indented.

"Wait a moment!", you might say, "Wouldn't it have been easier to just click on Format > Paragraph, then change the indentation?" Yes, for one paragraph it might indeed have been easier, but what if you indented lots of paragraphs, then decide that things would look much nicer if all of your manually indented paragraphs should also be a bit separated from each other, as well as regular paragraphs? With styles, this is a breeze - we just change the style you applied to the paragraphs in question.

To change the "First line indent" style, right click it and select "Modify". Switch to the "Indents & Spacing" tab and change the value of the "Above Paragraph" spacing to something higher. Click OK and you will see that immediately all paragraphs that had the "First line indent" style applied are now spaced a bit apart.

But wait, there's more. Because styles help Writer see the logical structure of your document instead of just it's physical layout, it can act in a much more sensible way - a Heading means a lot more to Writer than just big, bold text. One example: If you used heading styles while laying out your text, inserting a camera-ready table of contents is a matter of four clicks: We choose Insert > Indexes and Tables > Indexes and Tables..., then just accept the defaults by clicking OK. If your Browser conserved the headings in this text while copying it over to Writer you will see a brand-new table of contents in your document that lists all the headings in your text, along with their page numbers.

Let's try something and insert a new heading. Insert a new, short line of text somewhere in your document, click somewhere on that line, then double-click the "Heading 1" style to make this paragraph a new heading. Now let's have a look at our table of contents. If everything worked alright... ...nothing changed. Yes, that's right. If Writer were to constantly update a table of contents at the start of your text it would be continuously shifting up and down when the length of the table of contents changes. That's why it's only updated when you explicitly say so. So let's right-click the table of contents, then choose "Update Index/Table". If everything worked out alright, you will immediately get a table of contents that reflects your recent changes to the text. Easy, huh?

This concludes our short introduction to the Stylist. Go ahead, have some fun with it - there's lots of things to discover. Like outline numbering (check Tools > Outline Numbering...). Or styles for whole pages. Or - well, see for yourself!


Insert Numbered Equation=[edit]

Type fn and then press F3.