Wings 3D/User Manual/The Edit Menu

From Wikibooks, open books for an open world
< Wings 3D‎ | User Manual
Jump to: navigation, search

Undo/Redo Redo Undo[edit]

These are the traditional undo, redo the last action editing tools.

Repeat

Preferences

Plug-in Manager

Plug-in Preferences

Purge Undo History


48 DRAFT 1.6

� WINGS3D USER MANUAL Section 5.1 The Menus 5.1.2 The Edit Menu Figure 35: The Edit Menu. Edit Menu – General

The Edit Menu allows for operations which can directly affect your model such as Undo,

Redo, Repeat, and Repeat Drag. It is also where the user can set up their operational preferences so that Wings looks and behaves they way they prefer it to work.

EDIT | UNDO/REDO (Ctrl-Z) Reverses last action. The last Undo is redone, the last Redo is undone.

EDIT | REDO (Ctrl-Shift-Z) Redo undone steps, up to 32 steps.

EDIT | UNDO (Alt-Ctrl-Z) Undo up to the last 32 steps.

EDIT | REPEAT (D) Repeats the last command. Note that the menu will read (Cant repeat "some command") D if the selection mode has been changed and the command doesn't exist in the current selection mode. Also, if the selection has been cleared, no command can be repeated. There are limits on what can be repeated. Interactive commands, commands

where you drag, such as Extrude, will only be repeated up to when the dragging phase starts. You will have to do the dragging again, even if you want to drag exactly the same distance.

EDIT | REPEAT DRAG (Shift-D) Repeat Drag repeats both the command and the interactive actions taken with the command. In other words, the mouse drag portion of an extrude, for example, is also repeated. So if your did an Extrude on a face for 3 units selecting the Repeat Drag option (Shift-D) would not only start the Extrude command, but would also do the extrude the same distance.

DRAFT 1.6 49

� Section 5.1 The Menus WINGS3D USER MANUAL Figure 36: The Material Editor.

EDIT | MATERIAL

Default

Hole

Brings up the Material Editor. This both shows the current material settings for the included colors and allows you to set their properties. You can set the color for the default object and hole colors and any materials you have created via the Face | Set Material command. Editable properties include: Diffuse, Ambient, Specular, Emission, Shininess, and Opacity. Diffuse, ambient, specular, and emissive colors are set via pop-up color mixers while shininess and opacity are set via sliders. The resultant overall material is shown on the ball to the left. Here is a screen shot of the Material Editor.

Note that new materials are not created here. Use the FACE CONTEXT SENSITIVE MENU | SET MATERIAL | NEW to create a new material. Any new materials can then be edited via this EDIT | MATERIAL menu.

EDIT |CAMERA MODE

Wings provides users with the ability to set their own camera options so that you can work the way you like, rather than having to work in some predetermined manner. There are five camera options to choose from; Mirai®, Nendo®, Maya®, 3ds max®, and Blender. Additionally, there are options for setting up the scroll wheel for quick zooming with a user selected zoom factor. You can also set the field of view and the depth of the near and far clipping planes.

This allows you to set Wings up to work the way you are used to working if you have used any of the other 3D modeling packages listed. Each camera mode is briefly outlined below. Note that lmb means left mouse button, mmb means middle mouse button, and rmb means right mouse button. To make the settings take effect, click the OK button. To return to Wings without making any changes click on the Cancel button. A brief summery of the camera mode operations follows.

Figure 37: Camera modes. The Camera Mode sub menu has options to set the camera up to your liking. It also has settings to use the scroll wheel for zooming, the field of view, and the depth of the near and far clipping planes. 50 DRAFT 1.6

� WINGS3D USER MANUAL Section 5.1 The Menus Mirai® mode:

mmb click and release = rotate mode mmb scroll wheel = zoom arrow keys = translate view rmb = return the original view, prior to tumbling. Q = toggle rotate/translate while in rotate mode.

Nendo® mode:

mmb click = rotate mode while in rotate mode, (mmb or rmb) drag to zoom lmb to exit rotate mode arrow keys = translate view In Nendo® mode you may use Ctrlrmb click to enter rotate mode if you don't have a middle mouse button.

Maya® mode:

alt + lmb = rotate view alt + mmb = translate view alt + lmb + mmb = zoom view

3ds Max® mode:

mmb = rotate view ctrl + mmb = translate view alt + ctrl + mmb = zoom view

Blender mode:

mmb = rotate view Shift + mmb = translate view Ctrl + mmb = zoom view If you don't have a middle mouse button, use Alt + lmb instead.

Note that both the Max and Maya modes require a three-button mouse.

Perhaps a quick word on clipping planes is in order here. The near and far clipping planes are simply the area in your workspace between which objects or parts of objects remain visible. So with a near clipping plane setting of 0.25 any portion of the object that is closer to the camera than 0.25 Wings units will vanish. With a setting of 1000 for the far clipping plane any portion of an object greater than 1000 units from the camera will likewise become invisible. The most practical implication here is if you want to zoom in very close for detail work you may find the area of interest suddenly disappears. To solve this either zoom out slightly or reduce the near clipping plane setting to something smaller, like 0.01 units.

EDIT | PREFRENCES

Wings allows the user to set numerous user interface preferences. This is accomplished via a preference dialog sheet which is accessed by selecting Preferences from the Edit Menu. When the dialog sheet comes up, set each preference as desired, then click OK to apply them and dismiss the sheet. If you change your mind or don't want to set any preferences click the Cancel button to dismiss the dialog sheet without applying them. Above is a picture of the dialog sheet

as it is set in my working version of Wings. Note that by clicking on any of the color boxes a sub menu will pop up that allows you to set the colors interactively via RGB slider bars or by typing in individual vales for red, green, and blue. These settings are likewise set or abandoned via clicking on the OK or Cancel buttons respectively. Vertex Display – sets the size of the vertices on the screen in pixels. It is sometimes handy to increase vertex sizes to even as much as 12 – 16 pixels, for doing screen grabs, to help clarify a point on a discussion forum or in a tutorial. Edge Display – sets the size (thickness) of the edges on the screen in pixels. Colors – sets the Background, Text (workspace text), Selection, Edges, Hard Edges, and Wire Edges colors. By clicking on one of the boxes the color dialog box will come up allowing you to enter RGB values from 0-255. Enter each number then hit Return to accept the changes. You can drag and drop color patches from one box to another. Grid – the two options are Color, which works exactly as the Color options described above, and the Force Axis-Aligned Grid check box, which acts as a toggle. If turned on whenever you jump to a primary axis view (by hitting the X, Y, Z, Shift-X, Shift-Y, Shift-Z keys) the Grid will automatically turn on.

DRAFT 1.6 51

� Section 5.1 The Menus WINGS3D USER MANUAL When you move out of such a view the grid will automatically turn back off. Highlighting – Vertex, Edge, Face, and Object highlighting are also On/Off toggles. If turned on then the item of that type will auto highlight when the mouse passes over them. This makes selecting the correct vertex, edge, etc. much easier as it gives a visual confirmation of just what is being pointed at. If the item the mouse is over is unselected it will highlight in the unselected color whereas if it is selected the item will highlight in the Selected color. These colors are set just like the Color options as described above. The Smart Highlighting check box allows Wings to automatically switch from the various selection modes (vertex, edge, and face) similar to how it works in Nendo®. This can speed up modeling quite a bit. Vector Display – Vector Display Length and Width set just that, the length and width of the line used to represent the active Vector in the advanced menus operations. Vector Display Color sets the color of the Vector

Figure 38: The Preferences Menu.

used in the advanced menus operations. Colors are assigned just as described in the Color preferences section above. Auto Rotate – Auto Rotate Angel is entered as a real number in degrees of rotation. The Auto Rotate Delay is entered as an whole number, representing milliseconds between steps of rotation. The Auto Rotate function itself is accessed (and will be discussed) in the View menu structure. Axes – Show Axis Letters check box is an On/Off toggle. If turned on small X, Y, and Z letters will float at the + ends of the three axes, to help keep you oriented. The +X,Y,Z and -X, Y, Z Color boxes allows you to set the color for each axis which also helps keep you oriented while modeling. These are set by the color preferences boxes for each, just like in the Color options described above.


52 DRAFT 1.6

� WINGS3D USER MANUAL Section 5.1 The Menus Miscellaneous – There are several miscellaneous preferences as described below.

Auto-save interval (min) saves to a temporary file with the extension .wings_as. It will NOT overwrite the current file. If there is a crash, the next time you try to open the file (with .wings extension), you will get a prompt asking you if you want to load the auto-saved file instead. (It compares the date/time of the files.) Auto-save won't start before you have done a save-as once. If you turn off auto-save (0) and then turn it on again, the auto-start mechanism won't start until the next time you start wings. It's not used for imported files. Enabling Auto-save also enables the auto backup function of Wings. A backup file will be saved each time you save your work, i.e. your previous file will be stored as FILENAME.wings_bup. If you want to load a backup file use Open and look for *.wings_bup files.

Advanced Menus enables Wings advanced menus operations. If advanced menus are turned on then you can use some of the advanced manipulation tools designed by Chris Osgood which have been incorporated into Wings. Many of these functions operate on the premise of selecting and using a secondary vector as a reference about which the advanced functions work. These vectors are visible (if advanced menus are on) and their appearance characteristics of width and color are user definable via the Vector Display Width and the Vector Display Color options here.

Show Debugging Info works as a toggle. If activated, the amount of memory currently being used by Wings, the number of items in the display list and the number of binaries in use are displayed dynamically in the lower left of the workspace.

Another point, Wings keeps your custom preferences even when you upgrade to a new version.

Figure 39: Compatibility. Use the Edit|Compatibility Menu to fix display and operational problems if you have difficulties running Wings on your system. EDIT | COMPATIBILITY

The Compatibility menu allows the user to toggle on/off several options in Wings. These are; Optimize display lists, Use display lists for text, Show dummy axis letter, and Early back buffer clear. In general, you shouldn't change these options from their default values unless you have some sort of problem using Wings.

One-button mouse: The default is on. To use the default Wings/Blender camera mode on a Mac with a one-button mouse you must first enable this option. To emulate the middle mouse button hold down the [Alt/Option] key. To emulate the right mouse button hold down the [Command] key. This option has no effect on Windows or Linux® based systems.

Optimize display lists: This is a toggle that tells Wings to optimize how it handles the internal list of drawing elements for screen refreshment. It is generally recommended that this option be set to On. However, some combinations of drivers/graphics card seems to handle it incorrectly, causing Wings to crash with a General Protection Fault or similar. So if you have display problems or crashes, try turning this off to see if that solves the problem. The default setting is on, which is the fastest setting.

Use display lists for text: The default is on. If text doesn't show up in menus and other places, try turning off this option. (Known to be an issue on some Matrox cards.)

DRAFT 1.6 53

� Section 5.1 The Menus WINGS3D USER MANUAL Show dummy axis letter: The default is off. If Wings crashes when trying to open menus when the axes and/or axis letters are turned off, try turning on this option. (Known to be an issue on some Matrox cards.)

Early back buffer clear: The default is off on Mac OS X and default on on all other platforms. There is probably no reason to change this option.

There are two screen buffers, a front buffer and a back buffer. The front buffer is what you currently see on screen. The back buffer is used for drawing what you will see next. When everything is drawn, the buffers are swapped.

On all platforms but Mac OS X, Wings clears the back buffer immediately after swapping (because that is somewhat faster). That is what Björn calls "early clear". On Mac OS X, it seems that the back buffer can be used by the OS, which resulted in a blank Wings window. When the option is turned off, Wings does a "late clear", i.e. it will clear the back buffer immediately before starting to draw in it.

EDIT | PURGE UNDO HISTORY

This will purge the undo history, as stated. If you purge the history, you will not be able to

UNDO changes to your model. The function is intended to reclaim memory. It is especially useful in one situation; when smoothing large models. If you find that you are running out of memory, purge the undo history after each smoothing.

Quick Tip: Repeat and the Function Keys

You can do some quick and easy modifications to a model through the combination of the Repeat (D) and Repeat Drag (Shift+D) operations and the F3/F4 (Next Loop/Previous Loop) keys. The Repeat and Repeat Drag operations can be performed over and over again on successive loops as you F3 and F4 your way up and down a portion of your model. A simple example would be, if you wanted to make a segmented body, such as a worm. You could start with a many segmented cylinder, then choose the first loop that you wanted to adjust and do a Scale | Uniform. Then you would hit F3 twice to move up two loops and reapply the Scale | Uniform by simply hitting Shift+D. Or to make the worm tapered, hit D and use the mouse to adjust the amount of scaling. Keep repeating the process until you have the entire cylinder done.