Wings 3D/User Manual/Index

From Wikibooks, open books for an open world
< Wings 3D‎ | User Manual
Jump to: navigation, search

DRAFT 1.6 125

� COMPLETE SHORTCUT KEY LIST WINGS3D USER MANUAL OVERVIEW OF CONTENTS


Copyright information: 4 Table Of Contents 5 List Of Figures 6 INTRODUCTION 8 Section 1: Installation 9

1.1 Windows ..............................................................................................................9 Quick Tip: Plugins don’t work with all versions of Wings3D..........................................9 1.3 Solaris®................................................................................................................9 1.4 Mac.....................................................................................................................9 1.2 Linux®................................................................................................................10 Section 2: The Wings3D User Interface 11 2.1 General Overview..................................................................................................12 2.2 The Title Bar........................................................................................................13 2.3 The Menu Bar .....................................................................................................13 2.4 The Icon Bar........................................................................................................13 2.5 The Status Bar ....................................................................................................14 2.6 Dialog Boxes........................................................................................................14 2.7 Context Sensitive Menus........................................................................................14 2.7 Context Sensitive Menus........................................................................................15 2.8 The Information String...........................................................................................15 2.8 The Information String...........................................................................................16 2.9 Wings Units ........................................................................................................16 Quick Tip: Working With Wings Units ...................................................................16 Section 3: A Quick Start Guide 17

3.1 Finger exercises to get you started..........................................................................17 Quick Tip: The Nature of Normals ...........................................................................19 3.2 Your First Real Model; a Dog House........................................................................20 3.3 Creating A Hand (an intrinsically organic shape) .......................................................27 3.4 Adding Detail.......................................................................................................31 3.5 Finishing It Off......................................................................................................35 Quick Tip: Overlaying the wireframe on a smooth shaded view...................................36 Section 4: The Nature of Subdivision Modeling 40 Section 4: The Nature of Subdivision Modeling 41

4.1 Subdivision and Such.............................................................................................41 4.2 The Nature of Edge Loops .....................................................................................43 4.3 Winged Edge Topology..........................................................................................44 4.3 Winged Edge Topology..........................................................................................45 Section 5: The Wings3D Command Reference Guide 46 5.1 The Main Menu....................................................................................................46 5.1.1 The File Menu...................................................................................................46 File Menu – General 46 File | New (Ctrl-N).................................................................................................46 File | Open (Ctrl-O).................................................................................................46 FILE | MERGE (Ctrl-L).............................................................................................47 File | Save (Ctrl-S) .................................................................................................47 FILE | SAVE AS (Ctrl-Shift-S)....................................................................................47 FILE | SAVE SELECTED...........................................................................................47 FILE | REVERT......................................................................................................47 File | Import.........................................................................................................47 FILE | EXPORT......................................................................................................48


126 DRAFT 1.6

� WINGS3D USER MANUAL REFERENCES Quick Tip: Rendering with YafRay......................................................................... 48 FILE | EXPORT SELECTED .......................................................................................48 FILE | RENDER......................................................................................................48 FILE | HISTORY .....................................................................................................48 FILE | EXIT (Ctrl-Q).................................................................................................48


5.1.2 The Edit Menu...................................................................................................49 Edit Menu – General 49 EDIT | UNDO/REDO (Ctrl-Z) ....................................................................................49 EDIT | REDO (Ctrl-Shift-Z) ........................................................................................49 EDIT | UNDO (Alt-Ctrl-Z)..........................................................................................49 EDIT | REPEAT (D) .................................................................................................49 EDIT | REPEAT DRAG (Shift-D) .................................................................................49 EDIT | MATERIAL ..................................................................................................50 EDIT |CAMERA MODE............................................................................................50 Mirai® mode: 51 Nendo® mode: 51 Maya® mode: 51 3ds Max® mode: 51 Blender mode: 51 EDIT | PREFRENCES ..............................................................................................51 EDIT | COMPATIBILITY ...........................................................................................53 EDIT | PURGE UNDO HISTORY.................................................................................54 Quick Tip: Repeat and the Function Keys............................................................... 54 5.1.3 The View Menu .................................................................................................55 View Menu – General 55 VIEW | GROUND PLANE.........................................................................................55 VIEW | AXES ........................................................................................................55 VIEW | WORKMODE (Tab) ......................................................................................55 VIEW | SMOOTH PREVIEW (Shift-Tab).......................................................................55 VIEW | WIREFRAME..............................................................................................55 VIEW | SHADE......................................................................................................55 VIEW | TOGGLE WIREFRAMED/SHADED (W) ............................................................55 VIEW | SHOW SAVED BB.......................................................................................56 VIEW | SHOW EDGES ............................................................................................56 VIEW | SHOW NORMALS.......................................................................................56 VIEW | SHOW WIREFRAME BACKFACES ..................................................................56 VIEW | RESET VIEW (R)..........................................................................................56 VIEW | AIM (A) .....................................................................................................56 VIEW | FRAME (Shift+A) .........................................................................................56 VIEW | ORTHOGRAPHIC VIEW (O) ............................................................................56 VIEW | SCENE LIGHTS ...........................................................................................56 VIEW | ONE/TWO LIGHTS......................................................................................56 VIEW | SHOW COLORS ..........................................................................................56 VIEW | SHOW MATERIALS .....................................................................................57 VIEW | SHOW TEXTURES.......................................................................................57 VIEW | VIEW ALONG (X, Y, Z, Shift-X, Shift-Y, Shift-Z) .................................................57 VIEW | ALIGN TO SELECTION ..................................................................................57 VIEW | AUTO ROTATE (U).......................................................................................57


Quick Tip: View Orthographic in Wireframe Mode................................................... 57


5.1.4 The Select Menu ...............................................................................................59 SELECT MENU – GENERAL 59 SELECT | DESELECT (Space)....................................................................................59 SELECT | MORE (+)................................................................................................59 SELECT | LESS (-) ..................................................................................................59

DRAFT 1.6 127

� COMPLETE SHORTCUT KEY LIST WINGS3D USER MANUAL SELECT | REGION (Shift-L).......................................................................................59 SELECT | EDGE LOOP (L)........................................................................................59 SELECT | EDGE RING (G)........................................................................................59 SELECT | PREVIOUS EDGE LOOP (F3) .......................................................................60 SELECT | NEXT EDGE LOOP (F4)..............................................................................60 SELECT | SIMILAR (I) .............................................................................................60 SELECT | ADJACENT.............................................................................................60 SELECT | BY ........................................................................................................61 SELECT | LIGHTS ..................................................................................................61 SELECT | ALL [Vertices, Edges, Faces, Objects] (Ctrl+A)..............................................61 SELECT | INVERSE (Ctrl-Shift-I).................................................................................61 SELECT | STORE SELECTION...................................................................................61 SELECT | RECALL SELECTION .................................................................................61 SELECT | EXCHANGE SELECTION.............................................................................62 SELECT | UNION WITH STORED..............................................................................62 SELECT | SUBTRACT WITH STORED ........................................................................62 SELECT | INTERSECTION WITH STORED ...................................................................62 5.1.5 The Tools Menu................................................................................................63 Tools Menu – General 63 TOOLS | ALIGN.....................................................................................................63 TOOLS | CENTER ..................................................................................................63 TOOLS | SAVE BOUNDING BOX...............................................................................63 TOOLS | SCALE TO SAVED BB.................................................................................63 TOOLS | SAVE TO SAVED BB PROPORTIONALLY........................................................64 TOOLS | MOVE TO SAVED BB .................................................................................64 TOOLS | SET DEFAULT AXIS ...................................................................................64 TOOLS | VIRTUAL MIRROR.....................................................................................64 TOOLS | TWEAK...................................................................................................64


Quick Tip: Additional Tools...................................................................................65 Quick Tip: Bounding Boxes ..................................................................................65


5.1.6 The Objects Menu .............................................................................................66 Objects Menu – General 66 OBJECTS | SHOW AND UNLOCK ALL.......................................................................66 OBJECTS | HIDE SELECTED ....................................................................................66 OBJECTS | HIDE UNSELECTED................................................................................66 OBJECTS | LOCK UNSELECTED...............................................................................66 OBJECTS | {OBJECT LIST} (object1 would be cube1 for the example shown above.) .........66


5.1.7 The Help Menu .................................................................................................68 Help Menu – General 68 HELP | GETTING STARTED .....................................................................................68 HELP | USING A MOUSE WITH ONE OR TWO BUTTONS .............................................68 HELP | FRENCH AND GERMAN KEYBOARDS ............................................................68 HELP | LIGHT BASICS............................................................................................68 HELP | ASSIGNING HOTKEYS..................................................................................68 HELP | ADVANCED MENUS....................................................................................68 HELP | OPENGL INFO ............................................................................................68 HELP | ABOUT .....................................................................................................68


5.2 The Context Sensitive Menus..................................................................................69 5.2.1 The Primitives Menu..........................................................................................69 Primitives Menu – General 69 5.2.2 The Vertex Operations Menu...............................................................................72 Vertex Operations Menu – General 72 VERTEX MENU | MOVE..........................................................................................72 VERTEX MENU | SCALE.........................................................................................72

128 DRAFT 1.6

� WINGS3D USER MANUAL REFERENCES VERTEX MENU | EXTRUDE .....................................................................................73 VERTEX MENU | FLATTEN ......................................................................................73 VERTEX MENU | CONNECT (C) ................................................................................73 VERTEX MENU | TIGHTEN .....................................................................................73 VERTEX MENU | BEVEL..........................................................................................73 VERTEX MENU | COLLAPSE (Bksp)...........................................................................73 VERTEX MENU | DISSOLVE.....................................................................................73 VERTEX MENU | DEFORM ......................................................................................74 Some Examples: ............................................................................................... 74 Quick Tip: Experiment with Deformers .................................................................. 76


5.2.3 The Edge Operations Menu..................................................................................76 5.2.3 The Edge Operations Menu..................................................................................77 5.2.3 The Edge Operations Menu..................................................................................78 Edge Operations Menu – General 78 EDGE MENU | MOVE .............................................................................................78 EDGE MENU | ROTATE...........................................................................................78 EDGE MENU | SCALE.............................................................................................78 EDGE MENU | EXTRUDE.........................................................................................78 EDGE MENU | CUT................................................................................................79 EDGE MENU | CONNECT C .....................................................................................79 EDGE MENU | BEVEL.............................................................................................79 EDGE MENU | DISSOLVE (Bksp)...............................................................................79 Quick Tip: Creating round eyes from square holes. ................................................. 79 EDGE MENU | COLLAPSE .......................................................................................79 EDGE MENU | HARDNESS......................................................................................79 Quick Tip: Replace your hard edges with bevels...................................................... 80 EDGE MENU | LOOP CUT........................................................................................80 EDGE MENU | TURN..............................................................................................80 EDGE MENU | OPTIMIZED TURN .............................................................................80


5.2.4 The Face Operations Menu..................................................................................81 Face Operations Menu – General 81 FACE MENU | MOVE..............................................................................................81 FACE MENU | ROTATE ...........................................................................................81 FACE MENU | SCALE.............................................................................................81 FACE MENU | EXTRUDE.........................................................................................81 FACE MENU | Extrude Region..................................................................................82 FACE MENU | EXTRACT REGION..............................................................................82 FACE MENU | FLATTEN..........................................................................................82 FACE MENU | INSET..............................................................................................82 FACE MENU | INTRUDE .........................................................................................82 FACE MENU | BEVEL .............................................................................................83 FACE MENU | BRIDGE............................................................................................83 FACE MENU | BUMP .............................................................................................83 FACE | LIFT ..........................................................................................................83 FACE | PUT ON.....................................................................................................83 Quick Tip – Put On and Bridge............................................................................. 83 FACE MENU | MIRROR...........................................................................................83 Quick Tip: Fix that mirror plane............................................................................ 83 FACE MENU | DISSOLVE (Bksp) ...............................................................................83 FACE MENU | COLLAPSE........................................................................................84 FACE MENU | SMOOTH (S) .....................................................................................84 Quick Tip: Smooth To Check For Anomalies. .......................................................... 84 FACE MENU | SET MATERIAL..................................................................................84 FACE | TESSELATE ................................................................................................84


DRAFT 1.6 129

� COMPLETE SHORTCUT KEY LIST WINGS3D USER MANUAL 5.2.5 The Object Operations Menu ...............................................................................85 Object Operations Menu – General 85 OBJECT MENU | MOVE..........................................................................................85 OBJECT MENU | ROTATE.......................................................................................85 OBJECT MENU | SCALE.........................................................................................85 OBJECT MENU | FLIP............................................................................................85 OBJECT MENU | INVERT........................................................................................85


Quick Tip: Invert vs. Intrude. ................................................................................86 OBJECT MENU | TIGHTEN......................................................................................86 OBJECT MENU | SMOOTH (S).................................................................................86 OBJECT MENU | COMBINE.....................................................................................86 OBJECT MENU | SEPARATE ...................................................................................86 OBJECT MENU | CLEANUP.....................................................................................86 OBJECT MENU | AUTO-SMOOTH .............................................................................86 OBJECT MENU | DUPLICATE ..................................................................................87 OBJECT MENU | DELETE (Bksp or Del).....................................................................87 OBJECT MENU | MODE..........................................................................................87 OBJECT MENU | STRIP TEXTURE ............................................................................87 OBJECT MENU | UV MAPPING (experimental) ...........................................................87


5.4 A little tutorial......................................................................................................92 5.5 Advanced Menu Command Reference Guide.............................................................94 5.5.1 Vertex Operations with Advanced Menus...............................................................95 VERTEX | MOVE: Left Mouse Button (LMB)...............................................................95 VERTEX | ROTATE: LMB.........................................................................................95 VERTEX | SCALE: LMB...........................................................................................95 Vertex | Extrude: LMB...........................................................................................95 Vertex | Flatten: LMB............................................................................................95 5.5.2 Edge Operations with Advanced Menus.................................................................95 Edge | Move: LMB................................................................................................96 Edge | Rotate: LMB...............................................................................................96 Edge | Scale: LMB ................................................................................................96 Edge | Extrude: LMB .............................................................................................96 5.5.3 Face Operations with Advanced Menus.................................................................97 FACE | MOVE: LMB...............................................................................................97 FACE | ROTATE: LMB............................................................................................97 FACE | SCALE: LMB..............................................................................................97 FACE | EXTRUDE: LMB..........................................................................................97 FACE | EXTRUDE REGION: LMB...............................................................................97 FACE | EXTRACT REGION: LMB...............................................................................97 FACE | FLATTEN: LMB...........................................................................................98 FACE | LIFT:.........................................................................................................98 5.5.4 Body Operations with Advanced Menus.................................................................99 BODY | MOVE: LMB..............................................................................................99 Body | Rotate: LMB ..............................................................................................99 Body | Scale: LMB ................................................................................................99 Body | Duplicate: LMB...........................................................................................99 5.6 Reference Guide to Hot Key Assignments...............................................................100 Section 6: windows 102 6.1 OUTLINER.........................................................................................................102 Quick Tip: Drag and Drop..................................................................................102 6.2 Geometry graph.................................................................................................102 Section 6.3 UV Mapping ...........................................................................................103 UV MAPPING | SEGMENTING MODE......................................................................103 Continue 103

130 DRAFT 1.6

� WINGS3D USER MANUAL REFERENCES Continue | Projection 104 Continue | Unfolding 104 SEGMENT BY | PROJECTION 104 SEGMENT BY | FEATURE DETECTION 105 AuvChart1~9 105 Creating Cuts...........................................................................................................106 The Segmenting Right Click Menu 106 Mark edges for Cuts 106 Quick Tip: Using Cuts....................................................................................... 106 SEGMENT BY | FEATURE DETECTION 107 Quick tip: Updating the UV Maps after edits to the mesh....................................... 107 AUTO UV WINDOW ..................................................................................................108 Move 108 Scale 108 Rotate 108 Rescale all 108 ReMap UV 108 Draw Options 108 Apply Texture 108 Quit 108

Section 7: Plug-ins 109 Draw Loop Plug-in by clacos .................................................................................109 Extended Renderman Output Plug-in Additions made by Danni Coy (rgcoy@midcoast.com.au)109 Geodesic Dome Primitive Plug-in by Nathan Hauck....................................................110 POV-Ray Plug-in by This Guy (handle) ......................................................................110 Slide Plug-in by clacos..........................................................................................110 Text, AI, Triangulate, Quadrangulate, Tweak Plug-in by Howard Trickey (howardt) ..........110 Torus Plug-in by Anthony D'Agostino (scorpius) ........................................................111 Turn-edge plug-in by Chris Osgood (WingsOne).........................................................111 YafRay....................................................................................................................112 WINDOWS 112 MAC 113

Section 8: Resources 114

8.1 Wings3D Links...................................................................................................114 8.2 Polygon Modeling Links........................................................................................115 8.3 UVMapping and Texturing Links ............................................................................116 8.4 Rendering Links..................................................................................................117 8.5 Graphic Utilities ..................................................................................................118 8.6 Specialty Applications ..........................................................................................119 8.7 Books ...............................................................................................................120 Glossary 121 Credits: 124 1.2 Edition ..............................................................................................................124 1.6.1 Edition additions ..............................................................................................124 References 125 overview of Contents 126 DRAFT 1.6 131