Paint.NET/Keyboard Shortcuts

From Wikibooks, open books for an open world
< Paint.NET
Jump to: navigation, search

For Help Topics, press F1.

Tools[edit]

Select (S)[edit]

Press S to cycle between the four selectors:

  • Rectangle Select
  • Ellipse Select
  • Lasso Select
  • Magic Wand

Brief Descriptions of each:
Rectangle Select selects a rectangle. Drag from one corner to the opposite corner to draw. Hold Shift to keep it as a Square.
Ellipse Select selects a Circle/Oval. Drag like a rectangle, and it will draw a circle which touches each side. Hold in Shift to keep it as a Circle.
Lasso Select draws a shape and selects it dynamically. Just draw any old shape.
Magic Wand is, well... magical. Click on a pixel of one color and it will select all pixels adjoining that one of the same or similar color, then do the same on each pixel selected in this manner.

Paint Bucket[edit]

Just click wherever and it will fill with your primary color. Right-Click to fill with your alternate color.

Paintbrush (B)[edit]

Click and drag to draw a line of specified thickness.

Pencil (P)[edit]

Just like the Paintbrush, but it only has a thickness of 1 pixel.

Clone Stamp (L)[edit]

Copies one part of the image to another part of the image, selected as circles.

Text (T)[edit]

Click to create a text box. Type text in said text box, and use the Nub (Square with four arrows on) to move it around by dragging.

Shapes (O)[edit]

Use O to cycle between the five different parts of the Shape tool.

  • Rectangle
  • Ellipse
  • Rounded Rectangle
  • Freeform Shape
  • Lines/Curves

A brief description of each:
The Rectangle draws a rectangle. You can make it draw a rectangle border, solid rectangle or solid rectangle with border. Hold Shift to keep it square.
The Ellipse draws a circle or oval, like the Ellipse Select tool. As with the Rectangle tool, you can hold shift to keep it circular, and you can draw a border, solid shape or solid shape with border.
The Rounded Rectangle draws a rectangle with rounded corners. It is identical in every respect to the Rectangle tool.
The Freeform Shape tool is like the Lasso Select. It is also like the Rectangle tool. You can choose to draw a border, a solid shape or a solid shape with a border.
Lines/Curves is used to draw a straight line. Then, you can drag the four handles on the line around to bend the line to your will.

Color Replacer (R)[edit]

Replaces your alternate color with your primary color, and leaves other colors alone.

Eyedropper (P)[edit]

Click on a pixel to replace your primary color with the color of the pixel you clicked on. Simple enough. Right click to change your alternate color.

Eraser (E)[edit]

Fades all the pixels in the area of its effect to nothing, on the current layer.

Gradient (G)[edit]

Click at one point and drag to another. Having done that, it should be quite obvious.

Pan (H)[edit]

While zoomed in, use this tool to drag your way around the image.

Zoom (Z)[edit]

Left click to zoom in, right click to zoom out.

Move (M)[edit]

Use M to cycle between the two move tools.

  • Move Selection
  • Move Selected Pixels

A brief description of each:
Move Selection moves only your selected area. You can drag your selection circle all over the image and it will not affect the image in any way.
Move Selected Pixels moves the pixels you have selected on the current layer. So if you select a 10x10 square on layer A, then drag it 20 to the right, it will move that square on layer A but on layer B it will do nothing.

File Menu[edit]

New Image - Ctrl+N
Open Image - Ctrl+O
Close Image - Ctrl+W
Save - Ctrl+S
Save As - Ctrl+Shift+S
Print - Ctrl+P

Edit Menu[edit]

Undo - Ctrl+Z
Redo - Ctrl+Y
Cut - Ctrl+X
Copy - Ctrl+C
Paste
Normal - Ctrl+V
Into new Layer - Ctrl+Shift+V
Into new Image - Ctrl+Alt+V
Selections
Erase Selection - Delete
Fill Selection - Backspace [Fills your current selection with your Primary Color]
Invert Selection - Ctrl+I [Deselects what you have selected and selects what you didn't]
Select All - Ctrl+A
Deselect - Ctrl+D

View Menu[edit]

Zoom In - Ctrl+=
Zoom Out - Ctrl+-
Zoom to Window - Ctrl+B [Zooms so that your full image can be seen]
Zoom to Selection - Ctrl+Shift+B [Zooms so your selection fills the window]
Show Actual Size - Ctrl+Shift+A [Zooms to 100%]

Image Menu[edit]

Crop to Selection - Ctrl+Shift+X [Replaces your Image with your selection (Can be undone)]
Resize - Ctrl+W [Use to change all aspects of image, ie you can double the size]
Canvas Size - Ctrl+Shift+R [Use to change image area]
Rotate
90° Clockwise - Ctrl+H
90° Counter-Clockwise - Ctrl+G
180° (Upside Down) - Ctrl+J
Flatten - Ctrl+Shift+F [Combines/Merges all Layers into one]

Layers Menu[edit]

New Layer - Ctrl+Shift+N
Delete Layer - Shift+Delete
Duplicate Layer - Ctrl+Shift+D
Merge Layer Down - Ctrl+M [Merges the current layer into the one below]
Rotate/Zoom - Ctrl+Shift+Z [Rotate or Zoom only the current layer]
Layer Properties - F4 [Opacity, Blend Mode, Name]

Adjustments[edit]

Auto-Level - Ctrl+Alt+L
Black and White - Ctrl+Shift+G
Contrast - Ctrl+Shift+C
Curves - Ctrl+Shift+M
Hue/Saturation - Ctrl+Shift+U
Invert Colors - Ctrl+Shift+I
Levels - Ctrl+L
Sepia - Ctrl+Shift+P

Window[edit]

Show/Hide Tools Window- F5
Show/Hide History Window- F6
Show/Hide Layers Window - F7
Show/Hide Colors Window - F8
Show Image List - Ctrl+Q
Next Tab - Ctrl+Tab
Previous Tab - Ctrl+Shift+Tab