Inkscape/Shape Tools

From Wikibooks, open books for an open world
< Inkscape
Jump to: navigation, search

You will need to know how to draw basic shapes before you can draw more complex shapes. This page will teach you how to draw these shapes. The shape tools are useful because they allow you to make and manipulate basic forms easily.

All shapes have control handles that can be dragged to manipulate various aspects. Sometimes it's better to use the shape's resize handles, instead of the Selector's generic resize abilities. While the Selector resizes relative to the document, the shape tools will resize relative to the object. Experiment with both to see which works best for you. (Use Ctrl-Z to undo any changes you don't want to keep.) To restrain the resize handles, Ctrl-drag them. This limits movement to 15-degree steps. To change the step size, go to File > Inkscape Preferences and choose Steps.

Rectangles[edit]

A rounded rectangle with all handles extended.

Keyboard Shortcut - F4 or R

To draw a rectangle, select the rectangle tool and drag from the top left to the bottom right. Hold down Ctrl while dragging to create a ratio-proportionate rectangle (e.g. a square). Hold Shift while dragging to draw the rectangle from its center.

Rectangles have four handles: the square ones control the size and aspect ratio, the round ones control rounding of corners. (Shift-click the handle to remove rounding.) One rounding handle is vertical, and makes rectangles more circular; the other is horizontal, and makes rectangles more elliptical.

3D Boxes[edit]

The 3D Box tool is an easy way to create a 3-dimensional rectangle. To select only one side of a 3D box, Ctrl-click it.

Ellipses[edit]

The ellipse tool, describing a segment.

Keyboard shortcut - F5 or E

To draw an ellipse, circle, or an arc, select the ellipse tool (looks like a ellipse), and drag from the top left to the bottom right. The ellipse tool has four handles: two rectangular ones control the size and aspect ratio; two circular ones control the angle of the arc. Dragging the circular handles outside the ellipse makes a segment; dragging them inside creates an arc. Alt-click one of the circular handles to completely close the ellipse.

Stars and Polygons[edit]

Keyboard Shortcut - Shift-8

To switch between star and polygon, click the star-shaped or polygon-shaped icon in the Tool Controls bar of the Star/Polygon tool.

Stars and polygons have two handles: one outer handle, for stretching and rotation, and one inner handle, for skewing. Ctrl-drag the outer handle in order to stretch without rotating, and Ctrl-drag the inner handle to change the ratio of the two handles without skewing.

Spirals[edit]

Spiral tool, describing a spiral with 12 turns and a divergence of .25.

Keyboard shortcut - F9 or I

To draw a spiral, select the spiral tool and draw, observing the results. The spiral has two handles at each end of it-an inner one and an outer one. Dragging the handles lengthens and shortens the spiral.

Shift-drag the outer handle to scale and rotate the spiral.

Alt-drag the inner handle to change the divergence (distance between the loops). To make the distance really big, hold Alt and move the inner handle first towards the center, and then further in the same direction beyond the center, and possibly beyond the external boundary of the spiral. Spirals with a divergence less than 1 are denser towards the edges; ones with divergence greater than 1 are denser towards the center. To reset divergence, Alt-click the handle. Shift-click the handle to return it to the center.

Experiment with the handles and the Shift and Alt keys to get a grip on the tool.

Fill and Stroke[edit]

All shapes have a fill and a stroke. (One exception to this is the spiral, which should only be given a stroke.) The stroke is the outline of the shape. The fill is the area inside the shape. To set fill and stroke colors, select the shape and go to Object > Fill and Stroke, or press Ctrl-Shift-F. Objects can be filled with solid, flat color from the inkscape pallet, a linear or radial gradient fill, or a pattern fill.

Bitmap images[edit]

To insert a bitmap image—PNG or JPEG, paste it from the clipboard or drag and drop a bitmap file from the desktop. In this way, the images are only linked to, not embedded.

To turn some or all of the linked bitmap images into embedded images, use in menu Effects > Images > Embed images.


Interface · Path Drawing Tools