GIMP/Toolbox

From Wikibooks, open books for an open world
Jump to: navigation, search
Toolbox from GIMP 2.6

GIMP provides a comprehensive toolbox in order to quickly perform basic tasks. Toolbox is fully customizable, this means that you can add/remove any tool you want. Just go to "Windows > Dockable Dialogues > Tools", and select any tool you want.

By default not all tools are shown - GEGL operation tool and colour tools are omitted. All tools can also be accessed by opening the "Tools" menu. To switch the window to toolbox, you can use Ctrl + B. Note that shortcuts wrote here are the default values - you can change them any time you want in "Edit > Keyboard Shortcuts"

Tools[edit]

These tools are available by default in toolbox.

Icon Name Shortcut Description
Selection tools
GIMP-Toolbox-SelectionRectangle-Icon.png Rectangle R Selects square or rectangular regions.
GIMP-Toolbox-SelectionEllipse-Icon.png Ellipse E Selects circular or elliptical regions.
GIMP-Toolbox-SelectionLasso-Icon.png Free (Lasso) F Draw free-form selections.
GIMP-Toolbox-SelectionWand-Icon.png Fuzzy (Magic Wand) U Select continuous regions of colour.
GIMP-Toolbox-SelectionByColor-Icon.png By Colour Shift + O Select all instances of a colour in an image.
GIMP-Toolbox-SelectionScissors-Icon.png Scissors I Create paths to select shapes.
GIMP-Toolbox-SelectionForeground-Icon.png Foreground (none) Select a region containing foreground objects.
Brush tools
GIMP-Toolbox-BrushBucketFill-Icon.png Bucket Fill Shift + B Fills an area with a colour or pattern.
GIMP-Toolbox-BrushBlend-Icon.png Blend (Gradient) L Fills an area with a gradient.
GIMP-Toolbox-BrushPencil-Icon.png Pencil N Paints hard-edged lines; that is, the pixels are not anti-aliased.
GIMP-Toolbox-BrushPaintbrush-Icon.png Paintbrush P Paints soft- or fuzzy-edged lines; that is, the pixels are anti-aliased and/or feathered.
GIMP-Toolbox-BrushEraser-Icon.png Eraser Shift + E Erases pixels from a layer.
GIMP-Toolbox-BrushAirbrush-Icon.png Airbrush A Paint tool with variable pressure.
GIMP-Toolbox-BrushInk-Icon.png Ink K Paints anti-aliased lines with a simulation of a nib.
GIMP-Toolbox-BrushClone-Icon.png Clone C Copies pixels from one part of an image to another.
GIMP-Toolbox-BrushHeal-Icon.png Heal H Heals image irregularities.
GIMP-Toolbox-BrushPerspectiveClone-Icon.png Perspective Clone (none) Clone from an image source after applying perspective transformation.
GIMP-Toolbox-BrushConvolve-Icon.png Convolve (Blur/Sharpen) Shift + U Blurs or sharpens an image.
GIMP-Toolbox-BrushSmudge-Icon.png Smudge S Spreads pixels in the direction of a "push".
GIMP-Toolbox-BrushDodgeBurn-Icon.png Dodge/Burn Shift + D Lightens or darkens an image's shadows, mid tones, or highlights.
Transform tools
GIMP-Toolbox-TransformMove-Icon.png Move M Moves layers and selections.
GIMP-Toolbox-TransformAlign-Icon.png Align Q Align or arrange layers and/or other objects.
GIMP-Toolbox-TransformCrop-Icon.png Crop Shift + C Crops or clips the image.
GIMP-Toolbox-TransformRotate-Icon.png Rotate Shift + R Rotates the active layer, selection or path.
GIMP-Toolbox-TransformScale-Icon.png Scale Shift + T Scales the active layer, selection or path.
GIMP-Toolbox-TransformShear-Icon.png Shear Shift + S Shifts part of the image to some direction.
GIMP-Toolbox-TransformPerspective-Icon.png Perspective Shift + P Changes the perspective of the active layer, selection or path.
GIMP-Toolbox-TransformFlip-Icon.png Flip Shift + F Flips layers and selections.
Other tools
GIMP-Toolbox-PathTool-Icon.png Path B Allows selecting and modifying paths.
GIMP-Toolbox-ColourPickerTool-Icon.png Colour Picker O Selects the colour of any image opened on your screen.
GIMP-Toolbox-MagnifyTool-Icon.png Magnify (Zoom) Z Alters the zoom level of the image.
GIMP-Toolbox-MeasureTool-Icon.png Measure Shift + M Shows distances and angles.
GIMP-Toolbox-TextTool-Icon.png Text M Places text into your image.

There are also some other tools, hidden by default. These tools need to be accessed from the "Tools" menu, or by showing them in toolbox (Windows > Dockable Dialogues > Tools).

Icon Name Shortcut Description
Colour tools
GIMP-Toolbox-ColourColourBalance-Icon.png Colour Balance (none) Modifies the colour balance of current selection or layer.
GIMP-Toolbox-ColourHueSaturation-Icon.png Hue-Saturation (none) Adjusts hue, saturation and lightness.
GIMP-Toolbox-ColourColourize-Icon.png Colourize (none) Renders current selection or layer into a grey scale image seen through coloured glass.
GIMP-Toolbox-ColourBrightnessContrast-Icon.png Brightness-Contrast (none) Adjusts brightness and contrast.
GIMP-Toolbox-ColourThreshold-Icon.png Threshold (none) Transforms the current layer or selection into a black and white image.
GIMP-Toolbox-ColourLevels-Icon.png Levels (none) Changes the intensity range of the active layer or selection in every channel.
GIMP-Toolbox-ColourCurves-Icon.png Curves (none) Changes the colour, brightness, contrast or transparency of the active layer or path.
GIMP-Toolbox-ColourPosterize-Icon.png Posterize (none) Reduces the number of colours.
GIMP-Toolbox-ColourDesaturate-Icon.png Desaturate (none) Converts all colour to the corresponding shades of grey.
Other tools
GIMP-Toolbox-GEGLOperationTool-Icon.png GEGL operation (none) Executes a GEGL operation.

Tool options[edit]

GIMP-Toolbox-ToolOptions-All.png

By default, activating any tool, will have the effect of showing its options under the toolbox. Each tool has its own set of settings and any changes to them are kept through the current session. There are also four buttons under any options.

  • GIMP-Toolbox-ToolOptions-SaveOptions-Icon.png Save options to... - save options of the current tool
  • GIMP-Toolbox-ToolOptions-RestoreOptions-Icon.png Restore options from... - restore options from saved file
  • GIMP-Toolbox-ToolOptions-DeleteOptions-Icon.png Delete saved options... - delete saved options
  • GIMP-Toolbox-ToolOptions-ResetOptions-Icon.png Reset to default values - reset the settings to default values.

You can hide them by clicking on the arrow next to the tool name and deselecting Show Button Bar. You can also access these from the same menu under Tool Options Menu.

Colour, Indicator and Active Image area[edit]

Colour, Indicator and Active Image areas respectively.

Below the toolbox can be placed these three areas. This is set in "Edit > Preferences > Toolbox" and any of the three can be hid there.

Colour area[edit]

Shows current foreground and background colour. Clicking on either will bring up the colour editor dialogue.

Clicking on the symbol in the lower left corner resets the colour to their defaults. The D key has the same effect.

Clicking on the symbol in the upper right corner swaps the foreground and background colours. The X key has the same effect.

Indicator area[edit]

Shows currently selected brush, pattern or gradient. Clicking on any of these allows you to change it.

Active Image area[edit]

Displays a thumbnail of the active image. Clicking on it will bring the Images dialogue up, allowing you the select an image.

Introduction · Gradient

Introduction · GIMP · Gradient