Blender 3D: Noob to Pro/Quickie Render

From Wikibooks, open books for an open world
Jump to: navigation, search
Blender-2.5 quickie model render.png

If you haven't completed the "Quickie Model" module, do so now. You will need the resulting model for this module.

Now that you've created your first model, you'll probably want to try rendering it. Your first render, with a single light source and only nine faces, should finish quickly. However, as your 3D scenes become more complex, you'll find that rendering can take a long time.

In this module, you'll render your quickie model and save the result in various file formats. You'll also learn how to aim cameras and create lamps.

Rendering the Quickie Model[edit]

  1. Launch Blender and load factory settings.
  2. To load the house model from the previous module:
    1. Press  F1  or select File → Open. This temporarily changes the active window into a File Browser window.
    2. Navigate to the directory (folder) where you wrote the file, by clicking  LMB  on directory names in the File window. (Clicking on ".." will take you up one level.)
    3. Click  LMB  on the name of the file you wrote.
    4. Click  LMB  on the "Open File" button. As soon as the operation is complete, the window will revert back to its former type.
  3. Press  F12  or select Render → Render Image. This opens the Image Editor so you can watch the render progress.
If F12 is in use by the window manager...
  • With the new Apple keyboard, use  Fn + F12  to avoid the Mac Dashboard.
  • With Macintosh OS X 10.5, use  Alt + Fn + F12 .
  • With Gnome, use  Alt + F12  to avoid the Gnome Search Dialog.


Note:

You can stop a render in progress by pressing  Esc  any time when the render window has the focus. Bear in mind that this will stop the rendering of the current frame and abandon any partial results; pressing  F12  will start rendering the image from the beginning again.

 

Seeing Your Render[edit]

By default, pressing  F12  will switch to the UV/Image Editor window, and show you your render there. You can switch back to the 3D view with  F11 . Pressing  F11  in the 3D view will switch you to the UV/Image Editor window without redoing the render—you will simply see the same image as last time.

Aiming the Camera[edit]

If you don't get a picture of the house, or if the picture is not framed well, try moving or re-aiming the camera:

  1. Press  Esc  to get back to Edit Mode, if needed.
  2. Press  Num0  to take the camera's viewpoint.
  3. Press  Shift + F  to put the 3D View window into camera fly mode.

In camera fly mode, you can:

  • Pan and tilt by moving the mouse pointer up, down, left, or right.
  • Accelerate by  SCROLL  forwards.
  • Decelerate by  SCROLL  backwards.
  • Press any key or button to exit fly mode.

(It works differently in version 2.70 and later, more like a FPS game with possibility to slide and so on, buttons are regular FPS controls)

When you're done positioning the camera, try rendering again.

Lighting[edit]

If your cube is completely black, you may not have a lamp in the scene. Either the default lamp got deleted, or you're using a version of Blender that doesn't provide a default lamp.

To add a lamp:

  1. Make sure Blender is in Object Mode.
  2. Place the 3D cursor where you want the lamp to go; or add the lamp then immediately grab it, and move it somewhere else.
  3. Press  Shift + A .
  4. In the popup menu, select Lamp → Point.

Saving the Render[edit]

Saving the scene (with  F2 , for instance) does not save any renders. Saving renders is a separate step.

To save your current render:

  1. Make sure you are in the Image Editor. If not press  F12  to render
  2. Press  F3 . This temporarily changes the active window into a File Browser window.
  3. Navigate to the directory (folder) where you want to write the file.
  4. Type a filename in the text box (to the left of the "Cancel" button).
  5. To the left of the window, choose your preferred file type.
  6. Click  LMB  on the "Save as Image" button. As soon as the save operation is complete, the window will revert back to its former type.

Renderer Selection[edit]

Blender263RendererSelectionMenu.png

Blender offers a choice of different rendering engines for producing images. The menu for selecting from these appears in the Info window (the thin one that contains the menu bar at the top of the default layout). In most of these tutorials, you will leave this choice set at Blender Render. But it is worth knowing what other choices are available:

  • Blender Render—the oldest renderer, commonly known as the Blender Internal renderer. Built into Blender right from its early days. Can still produce good results with the right tricks, but considered by the Blender developers to be antiquated and not worthy of continuing development.
  • Blender Game—this is the renderer used by the Blender Game Engine. Designed to be fast enough for interactive use in a game, which means there are limitations in the quality of renders it produces. You also use this renderer to create rigid-body physics simulations.
  • Cycles Render—for this and other choices, see Advanced Rendering.

Render Control[edit]

Blender263RenderRender.png

The top panel under the Render tab Blender255RenderContextButton.png in the Properties window shows 3 buttons and a menu. The first button renders a single frame, equivalent to  F12 . The other two buttons are more relevant to animations.

Blender263RenderDisplayMenu.png

The “Display:” menu controls what happens when you press  F12 : the default “Image Editor” causes the 3D view to be switched to the UV/Image Editor showing the rendered image. “Full Screen” causes the UV/Image Editor display to take over the entire screen, while “New Window” makes it appear in a separate OS/GUI window (similar to how older versions of Blender used to work). Finally, “Keep UI” causes no changes to your window layout at all; you have to explicitly bring up the Image Editor with  F11  to see the rendered image.

Render Image Dimensions[edit]

Blender263RenderDimensions.png

You can control the size of image that Blender creates when rendering. This is specified in the “Dimensions” panel under Render Blender255RenderContextButton.png properties. Apart from the menu at the top, the settings in this panel are grouped into two columns:

  • The column on the left controls settings for a single image.
  • The column on the right specifies additional settings for rendering a whole sequence of images as part of an animation. These settings will be discussed later.

At the upper left, under “Resolution:”, we have the dimensions in pixels of the image (the default settings are 1920×1080 as shown in the screenshot), plus an additional scale factor slider below (showing 50% by default). With these settings, the image will actually be rendered at (1920×50%)×(1080×50%) = 960×540. Having the scale factor is a convenience; rendering smaller, lower-quality images is faster, which speeds things up when you are initially working on your model, but of course you want full quality for the final result. Instead of mentally having to work out numbers for initial- versus final-quality renders, you can simply set the resolution to the full final quality, and use the scale factor to reduce this to, say, 50% or 25% for interim work, and then set it to 100% for the final output.

Image File Formats[edit]

Blender263RenderFormats.png

You set the format and location for saving rendered images in the “Output” panel under the Render Blender255RenderContextButton.png properties.

In current versions of Blender, the default format for saving rendered images is PNG. This is a lossless format which has the option for alpha transparency (which means the sky background is replaced by transparent pixels—enabled by clicking the “RGBA” button). This is a good format if you intend to do further work with the image (e.g. in an image editor like Gimp or Photoshop), but the files can be large.

JPEG is a lossy image format, which means it throws away information that the human eye doesn’t see. This produces much smaller files than PNG, and is adequate if you just want to upload the render directly for use in a Web page or other such document, but is not the best choice if you intend to do further processing of the image. It also doesn’t support alpha transparency.

To change the render file format:

  1. Switch to the Render tab in the Properties window.
  2. Look for the “Output” panel.
  3. Click  LMB  on the popout menu with the current file format.
  4. Select your preferred format.

Additional Resources[edit]