Adobe GoLive Guide/Page Creation and Layout

From Wikibooks, open books for an open world
Jump to: navigation, search

This chapter focuses on creating and formatting web pages using Adobe GoLive


Adding and Formatting Pages[edit]

Pages can be created from within GoLive or added from without. Any time you choose to add a page, image or other object to your site, do so by dragging these files into the site window. This allows you to use the file in your site without effecting the original files and allows GoLive to keep track of and maintain your files/links.

Creating a New Page[edit]

While it is possible to create a page by selecting New Page (Ctrl +N) from the File menu, it is often more efficient to create each page as part of the site. There are several ways to do this.

  1. Make sure that the site window is open and the Files or Extras tab is selected.
  2. Site > New > Page
  1. Select a page from the Files tab in the site window.
  2. Edit > Duplicate
  • Drag a page onto the Files or Extras tab from the Objects palette.
  • In navigational view, follow the instructions above dragging the page next to any other page.

Formatting Pages[edit]

Aspects like backgrounds, margins and keywords (used for searches) can be added before or after the creation of the rest of the page.

Page Titles[edit]

The page title appears at the top of most browsers.

  • Select the page in the site window, then open the Page tab in the inspector. Enter a new title in the Title text box.
  • Open the document window and click on the "Title" label at the top of the window. Enter a new title.

Page Margins[edit]

Page margins determine how close the contents of a Web page come to the browser window.

  1. Special > Page Properties
  2. Click Page tab.
  3. Change Margin Width and Height.
  • To quickly remove page margins right click on page. Select Document > Set Page Margins to Zero.

Window Size[edit]

You can choose to set the page layout to a certain size to help design your page to that size. The following will not actually effect the size of the browser window. Use Java Script to change the size of the browser window.

  • In document view select a size from the Layout Dimensions menu in the bottom right hand corner of the window.
  • To change the size for all document windows, follow the instructions above and then open the Settings window from the Layout and Dimensions menu. Check the box labeled Markup Document Windows.